Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228699 - 2.6.20-1.2925.fc7 kernel fails to find disks (IDE & SCSI)
Summary: 2.6.20-1.2925.fc7 kernel fails to find disks (IDE & SCSI)
Keywords:
Status: CLOSED DUPLICATE of bug 220470
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 15:55 UTC by James Morris
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-23 19:03:32 UTC


Attachments (Terms of Use)
Good boot log from 2.6.18-1.2798.fc6 kernel (deleted)
2007-02-14 15:55 UTC, James Morris
no flags Details
Bad boot log for kernel 2.6.20-1.2925.fc7 (deleted)
2007-02-14 15:57 UTC, James Morris
no flags Details

Description James Morris 2007-02-14 15:55:58 UTC
Description of problem:

The 2.6.20-1.2925.fc7 kernel does not find my SCSI disks or CD drive, while the
2.6.18-1.2798.fc6 kernel does.

Version-Release number of selected component (if applicable):
2.6.20-1.2925.fc7

How reproducible:

Always

I've attached good & bad boot logs, for the earlier & later kernels respectively.

Here's how the IDE init looks on the good kernel:

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SvrWks CSB5: IDE controller at PCI slot 0000:00:0f.1
SvrWks CSB5: chipset revision 147
SvrWks CSB5: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x08b0-0x08b7, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0x08b8-0x08bf, BIOS settings: hdc:DMA, hdd:pio
hdc: SONY CD-RW CRX216E, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
ide-floppy driver 0.99.newide

Then, the SCSI hardware is not detected either (good version as follows):
mptbase: Initiating ioc0 bringup
input: ImPS/2 Generic Wheel Mouse as /class/input/input1
ioc0: 53C1030: Capabilities={Initiator}
scsi0 : ioc0: LSI53C1030, FwRev=01000c00h, Ports=1, MaxQ=255, IRQ=177
  Vendor: SEAGATE   Model: ST336732LW        Rev: 2227
  Type:   Direct-Access                      ANSI SCSI revision: 03
 target0:0:0: Beginning Domain Validation
 target0:0:0: Ending Domain Validation
 target0:0:0: FAST-160 WIDE SCSI 320.0 MB/s DT IU QAS HMCS (6.25 ns, offset 63)
SCSI device sda: 71132959 512-byte hdwr sectors (36420 MB)
sda: Write Protect is off
SCSI device sda: drive cache: write through w/ FUA
SCSI device sda: 71132959 512-byte hdwr sectors (36420 MB)
sda: Write Protect is off
SCSI device sda: drive cache: write through w/ FUA
 sda: sda1 sda2
sd 0:0:0:0: Attached scsi disk sda


See attachements for full logs.

Comment 1 James Morris 2007-02-14 15:55:58 UTC
Created attachment 148058 [details]
Good boot log from 2.6.18-1.2798.fc6 kernel

Comment 2 James Morris 2007-02-14 15:57:24 UTC
Created attachment 148059 [details]
Bad boot log for kernel 2.6.20-1.2925.fc7

Comment 3 James Morris 2007-02-14 17:11:56 UTC
Further info: 2.6.19-1.2895.fc6 works ok.

Comment 4 Jarod Wilson 2007-02-14 21:08:39 UTC
Possible dupe of bug 220470.

Comment 5 Dave Jones 2007-04-23 19:03:32 UTC

*** This bug has been marked as a duplicate of 220470 ***


Note You need to log in before you can comment on or make changes to this bug.