Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228671 - package-cleanup dies with TypeError: list objects are unhashable
Summary: package-cleanup dies with TypeError: list objects are unhashable
Keywords:
Status: CLOSED DUPLICATE of bug 212095
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 11:36 UTC by Lubomir Kundrak
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-14 14:36:46 UTC


Attachments (Terms of Use)

Description Lubomir Kundrak 2007-02-14 11:36:16 UTC
Description of problem:

I attempted to launch package-cleanup for the first time.
It died without a reason I would understand.

Version-Release number of selected component (if applicable):

yum-utils-1.0.1-1.fc6

How reproducible:

Always, for me.

Steps to Reproduce:

# package-cleanup --problems
 
Actual results:

Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package libtheora requires libogg.so.0
Package kdemultimedia requires libogg.so.0
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 349, in ?
    main()
  File "/usr/bin/package-cleanup", line 346, in main
    provsomething = buildProviderList(my,pkgs,opts.problems)
  File "/usr/bin/package-cleanup", line 85, in buildProviderList
    resolve_sack = my.rpmdb.whatProvides(req,rflags,ver)
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 390, in whatProvides
    pkgs = self.searchProvides(name)
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 141, in
searchProvides
    return self.searchPrco(name, 'provides')
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 123, in searchPrco
    if not result.has_key(po.pkgid):
TypeError: list objects are unhashable
#

Expected results:

Documented behavior.

Additional info:

I know _nothing_ about Python. Please excuse me if the information
I provided is not enough to trace the problem.

Comment 1 Tim Lauridsen 2007-02-14 14:36:46 UTC

*** This bug has been marked as a duplicate of 212095 ***


Note You need to log in before you can comment on or make changes to this bug.