Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228664 - Module bcm43xx crash kernel with mem >1G
Summary: Module bcm43xx crash kernel with mem >1G
Keywords:
Status: CLOSED DUPLICATE of bug 228665
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL: ftp://lwfinger.dynalias.org/patches/
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 09:45 UTC by Vladimir N.Chernenkov
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-14 09:58:35 UTC


Attachments (Terms of Use)

Description Vladimir N.Chernenkov 2007-02-14 09:45:06 UTC
Description of problem:

If actual size of memory on motherboard is <=1024M 
the all work OK. You may boot kernel-2.6.19-1.2895.fc6 with mem=1024M and
bigger phyzical size of memory, then working ok too.
But for default loading of the kenels up to kernel-doc-2.6.20-1.2922.fc7 with
size of memory > 1G there is crashed by error in DMA operations.

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2895.fc6.x86_64, 
kernel-2.6.20-1.2922.fc7.x86_64

How reproducible:
Build the system with CPU AMD Opteron and 2048M of memory on
ASUS SK8N Motherboard with PCI TEW-403PI wireless adapter.

Steps to Reproduce:

1. Configure WiFi device BCM4306 802.11b/g with wpa_supplicant as eth1
2. modprobe bcm43xx 
3. service wpa_supplicant start

  
Actual results:


Expected results:


Additional info:
That problem is descrybed and resolved by Larry Finger`s pathes:
ftp://lwfinger.dynalias.org/patches/

Comment 1 Vladimir N.Chernenkov 2007-02-14 09:58:35 UTC

*** This bug has been marked as a duplicate of 228665 ***


Note You need to log in before you can comment on or make changes to this bug.