Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228656 - plague list email xxx@xxx.yy causes traceback
Summary: plague list email xxx@xxx.yy causes traceback
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: plague
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 08:28 UTC by Hans de Goede
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-13 16:00:01 UTC


Attachments (Terms of Use)

Description Hans de Goede 2007-02-14 08:28:55 UTC
[hans@localhost FC-6]$ plague-client list email j.w.r.degoede@hhs.nl
Traceback (most recent call last):
  File "/usr/bin/plague-client", line 434, in <module>
    cli.dispatch(cmd, sys.argv[2:])
  File "/usr/bin/plague-client", line 379, in dispatch
    func(args)
  File "/usr/bin/plague-client", line 272, in _cmd_list
    (e, msg, jobs) = self._server.list_jobs(query_args)
  File "/usr/lib/python2.5/xmlrpclib.py", line 1147, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.5/xmlrpclib.py", line 1437, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.5/xmlrpclib.py", line 1201, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib/python2.5/xmlrpclib.py", line 1338, in _parse_response
    p.close()
  File "/usr/lib/python2.5/xmlrpclib.py", line 550, in close
    self._parser.Parse("", 1) # end of data
xml.parsers.expat.ExpatError: unclosed token: line 33358, column 23


This is on a pretty muchy fully up2date rawhide system

Comment 1 Michael Schwendt 2007-11-13 16:00:01 UTC
Cannot reproduce, and it would not be a bug in plague anyway
(but Python XMLRPC).

Btw, you might want to prefer something like:
plague-client list email j.w.r.degoede@hhs.nl uid_gt 34000



Note You need to log in before you can comment on or make changes to this bug.