Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228623 - FR: i8xx_tco support for Intel 6300ESB Watchdog timer
Summary: FR: i8xx_tco support for Intel 6300ESB Watchdog timer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jason Baron
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 00:29 UTC by George Akimov
Modified: 2013-03-06 05:59 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 16:20:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description George Akimov 2007-02-14 00:29:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9

Description of problem:
This feature request is about adding support for 8086:25ab PCI device (Intel 6300ESB Watchdog Timer) to i8xx_tco module. I found simple patch for that, applied it and recompiled the kernel. It works. The patch is at http://marc.theaimsgroup.com/?l=linux-kernel&m=110711973917746&w=2

Version-Release number of selected component (if applicable):
2.6.9-42.0.8

How reproducible:
Always


Steps to Reproduce:
1. modprobe i8xx_tco on any Intel 6300ESB mobo (Tyan S2198 in my case)
2.
3.

Actual Results:
FATAL: Error inserting i8xx_tco (...): No such device

Expected Results:
Kernel module loads and /dev/watchdog gets created

Additional info:

Comment 2 Jason Baron 2007-02-28 21:29:55 UTC
ok i've added just the PCI id to this driver, can you please try the test
kernels at: http://people.redhat.com/~jbaron/bz228623/ and let me know how they
work. thanks.

Comment 3 George Akimov 2007-02-28 22:43:19 UTC
Installed kernel-2.6.9-49.watch.1.EL and loaded "modprobe i8xx_tco" on Tyan
S2198 mobo. Dmesg reports:
"i8xx TCO timer: initialized (0x0460). heartbeat=30 sec (nowayout=0)"
Ran "echo '1' >/dev/watchdog; while ((1)); do date; sleep 1; done"
Hardware reset happens in 60 seconds, not in 30 as I expected. Maybe it takes 2
missing heartbeats? In any case, thanks, it works for me.

Comment 4 RHEL Product and Program Management 2007-06-20 15:36:15 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 5 Jason Baron 2007-06-20 19:39:53 UTC
committed in stream U6 build 55.10. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 7 Don Domingo 2007-08-24 03:50:27 UTC
added to RHEL4.6 release notes under "Kernel-Related Updates":

<quote>
Intel 6300ESB Watchdog timer is now supported
</quote>

please advise if any revisions are necessary. thanks!



Comment 9 errata-xmlrpc 2007-11-15 16:20:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html



Note You need to log in before you can comment on or make changes to this bug.