Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228617 - compiz-devel requires libdecoration.so.0
Summary: compiz-devel requires libdecoration.so.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-13 23:34 UTC by Jerry James
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-21 16:06:58 UTC


Attachments (Terms of Use)

Description Jerry James 2007-02-13 23:34:34 UTC
Description of problem:
yum update failed today because

--> Running transaction check
--> Processing Dependency: libdecoration.so.0 for package: compiz-devel
--> Finished Dependency Resolution
Error: Missing Dependency: libdecoration.so.0 is needed by package compiz-devel

This only happened on my x86_64 machines.  The i386 machines all happily upgraded.

Version-Release number of selected component (if applicable):
compiz-devel-0.3.6-2.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Install a previous version of compiz and compiz-devel
2. yum update

Actual results:
The yum update fails with the error message given above.

Expected results:
Yum should successfully update compiz and compiz-devel.

Additional info:

Comment 1 Jerry James 2007-02-22 03:20:40 UTC
It turns out that we had both the x86_64 and i386 versions of compiz-devel
installed.  Uninstalling the i386 version let the yum update go through.  This
means that the i386 compiz-devel currently in x86_64 updates is not installable.

Comment 2 Kristian Høgsberg 2007-08-15 22:41:28 UTC
I think I tracked this one down.  Is it possible for you to reproduce the same
setup and see if it is fixed with compiz-0.5.2-5.0ec3ec.fc8?  Thanks.

Comment 3 Jerry James 2007-08-16 20:21:47 UTC
I just changed jobs and moved and, alas, I no longer have access to an x86_64
machine.  I'm i686 only until I feel rich enough to buy a new computer. :-(

Comment 4 Kristian Høgsberg 2007-08-21 16:06:58 UTC
Heh, let me know if you get an x86_64 and still see this problem.  In the
meantime, I haven't seen this reported from anybody else, and I'll close this
for now.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.