Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228570 - Terminal visible on all workspaces in window list with compiz
Summary: Terminal visible on all workspaces in window list with compiz
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
: 241181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-13 20:26 UTC by Bojan Smojver
Modified: 2018-04-11 16:39 UTC (History)
5 users (show)

Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-19 15:19:31 UTC


Attachments (Terms of Use)

Description Bojan Smojver 2007-02-13 20:26:56 UTC
Description of problem:
When terminal (gnome-terminal in my case) is open using nautilus-open-terminal
(i.e. right click on desktop, then click "Open Terminal"), the terminal window
is visible in Window List on all workspaces. This does not happen when terminal
is open using the menu.


Version-Release number of selected component (if applicable):
0.3.6-2.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Update FC6 to latest compiz.
2. Run Gnome desktop with compiz.
  
Actual results:
Terminal visible in Window List on all workspaces.

Expected results:
Previously, terminal open through the menu and via nautilus-open-terminal would
behave the same.

Additional info:
I'm filing this as a compiz bug, because that how I discovered the behaviour,
but it may as well be a bug in Window List or something else. Not exactly sure.

Comment 1 Bojan Smojver 2007-02-13 20:27:32 UTC
One additional reference:

http://forum.go-compiz.org/viewtopic.php?p=3541&sid=db0ca3090f8229133368dd61d06102fa

Comment 2 Bojan Smojver 2007-02-14 03:55:20 UTC
If terminal is switched to xterm, this problem does not occur. Maybe something
to do with the way gnome-terminal is launched from nautilus-open-terminal
(nautilus-open-terminal.c):

----------------------------------
        if (g_str_has_prefix (terminal_exec, "gnome-terminal")) {
                dfile = lookup_in_data_dirs ("applications/gnome-terminal.desktop");
        } else {
                dfile = NULL;
        }

        g_shell_parse_argv (terminal_exec, NULL, &argv, NULL);

        display_str = NULL;
        old_display_str = g_getenv ("DISPLAY");

        screen = g_object_get_data (G_OBJECT (item),
"NautilusOpenTerminal::screen");
        if (screen != NULL) {
                display_str = gdk_screen_make_display_name (screen);
                g_setenv ("DISPLAY", display_str, TRUE);
        }

        if (dfile != NULL) {
                if (working_directory != NULL) {
                  if (chdir (working_directory) != 0)
                    g_assert_not_reached();
                }

                ditem = gnome_desktop_item_new_from_file (dfile, 0, NULL);

                gnome_desktop_item_set_string (ditem, "Exec", terminal_exec);
                gnome_desktop_item_set_launch_time (ditem,
gtk_get_current_event_time ());
                gnome_desktop_item_launch (ditem, NULL,
GNOME_DESKTOP_ITEM_LAUNCH_USE_CURRENT_DIR, NULL);
                gnome_desktop_item_unref (ditem);
                g_free (dfile);
        } else {
                g_spawn_async (working_directory,
                               argv,
                               NULL,
                               G_SPAWN_SEARCH_PATH,
                               NULL,
                               NULL,
                               NULL,
                               NULL);
        }
----------------------------------

The dfile is only used if the name is "gnome-terminal", which then causes Gnome
functionality to launch the app, rather than regular process spawn.

Maybe something needs to be told to gnome_desktop_item_launch() in order to not
do that?

BTW, I can't reach the nautilus-open-terminal home page at
http://manny.cluecoder.org/packages/nautilus-open-terminal/. I get a DNS error.
Not sure where the new home page for this software lives...

Comment 3 Paul W. Frields 2007-06-27 21:24:32 UTC
*** Bug 241181 has been marked as a duplicate of this bug. ***

Comment 4 Matěj Cepl 2007-11-01 12:10:20 UTC
Does anybody on the Cc: list still use FC6 and could reproduce this bug?

Comment 5 Radek Vokal 2007-11-01 12:26:42 UTC
yes

Comment 6 Bojan Smojver 2007-11-01 20:36:04 UTC
This is also a problem in F7. Not sure about F8 - haven't tried.

Comment 7 Bojan Smojver 2007-11-18 22:55:20 UTC
Fixed in F8. Feel free to close.

Comment 8 Matěj Cepl 2007-11-19 15:19:31 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.