Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228554 - theoretical problem: using of cciss and fibre in the same system; one will hide the other
Summary: theoretical problem: using of cciss and fibre in the same system; one will hi...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: YangKun
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-13 19:22 UTC by Rob Landry
Modified: 2008-07-16 21:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-14 03:26:10 UTC


Attachments (Terms of Use)

Description Rob Landry 2007-02-13 19:22:44 UTC
Description of problem:

From looking @ the code in storage.sh...

    if [ ${#STORAGE_DEVICES} == 0 ]; then
      if [ ${#STORAGE_DEVICES_CCISS} == 0 ]; then
        echo "  Error ! Can not find any block device to test ! "
        return 1
      else
        echo " Using cciss driver now. "
        STORAGE_DEVICES=$STORAGE_DEVICES_CCISS
      fi
    fi


...the above will only test cciss if no normal block devices are in the same
system even if instructed to do so.  I think get_storage_info and
get_storage_info_cciss are going to block the udi commands from the harness; and
because of the above you can't have both in the same system; because the value
of STORAGE_DEVICES will be set by the get_storage_info command and the _cciss
will be ignored.  Both should be detected and then limited by any udi or other
commands from the harness; it doesn't appear this will happen; though I haven't
found a cciss with a fibre card in it to prove this occurrs :(


Version-Release number of selected component (if applicable):

-21

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 YangKun 2007-02-14 02:55:14 UTC
the storage test will run in a per-UDI fashion, it will go through all storage
devices which planned in the plan.xml . cciss and fibre channel device should
have different UDIs, which means storage test will run on cciss and fibre
channel device separately. They should not "hide" each other in the test.

cciss is unique, HAL can not get the proper block-device name for cciss RAID
devices, so I made an ugly hack to find the cciss block-device name directly in
hwconf. 

The only possible reason for storage test not run on fibre channel device is :
HAL can not find the proper block-device name for it either. Then I'll add
something specific to that fibre channel device.

Sadly, I do not have either cciss or fibre device in hand to test... :(




Note You need to log in before you can comment on or make changes to this bug.