Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228542 - Kopete 0.12.4 (KDE 3.5.6) breaks crypto plugin
Summary: Kopete 0.12.4 (KDE 3.5.6) breaks crypto plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdenetwork
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL: http://bugs.kde.org/show_bug.cgi?id=1...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-13 18:09 UTC by Douglas E. Warner
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-20 15:04:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 140955 None None None Never

Description Douglas E. Warner 2007-02-13 18:09:35 UTC
Description of problem (from upstream):
kopete's crypto plugin doesn't decrypt messages. I can send properly encrypted 
messages (they're shown as ciphertext, though), but incoming encrypted 
messages are not decrypted. 
 
Also, kopete (or GPG) never ask for the passphrase, no matter if I enable "ask 
for passphrase" or use the gpg-agent. 
 
The very same setup used to work with kopete from kde 3.5.5!


Version-Release number of selected component (if applicable):
Kopete 0.12.4/KDE 3.5.6


How reproducible:
Send or receive GPG-encrypted IM in kopete; the output will not be decrypted.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Till Maas 2007-02-14 22:23:26 UTC
The bug seems to be easy to fix, just revert the change shown in
http://bugs.kde.org/show_bug.cgi?id=140955#c3

Comment 2 Douglas E. Warner 2007-03-02 15:06:39 UTC
Changed upstream bug link from http://bugs.kde.org/show_bug.cgi?id=140955 to 
http://bugs.kde.org/show_bug.cgi?id=134907

Comment 3 Rex Dieter 2007-06-20 15:04:10 UTC
The referenced patch is included in kde-3.5.7, which is currently in
updates-testing.  So, that should address this issue... closing.

Feel free to reopen if problems persist.


Note You need to log in before you can comment on or make changes to this bug.