Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228522 - quick IE fix for channel list views with expander
Summary: quick IE fix for channel list views with expander
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site
Version: rhn500
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-13 15:59 UTC by Máirín Duffy
Modified: 2007-04-18 17:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-21 13:18:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
fixed channel_tree.js (deleted)
2007-02-13 16:02 UTC, Máirín Duffy
no flags Details
screenshot of the IE issue - the above proposed fixes should fix this (deleted)
2007-02-13 16:03 UTC, Máirín Duffy
no flags Details

Description Máirín Duffy 2007-02-13 15:59:09 UTC
Description of problem:
There is an IE display problem with expand/collapse channel listviews. See bug
209375 for more info.

To fix this, the channel_tree.js needs to be updated (already done) and the
following attribute needs to be added to each child channel row in the listviews
listed below:

style="display: none;"

Pages this affects:

  (1) /rhn/software/channels/Relevant.do
  (2) /rhn/software/channels/All.do
  (3) /rhn/software/channels/Retired.do
  (4) /rhn/software/downloads/SupportedISOs.do
  (5) /rhn/software/downloads/AllISOs.do
  (6) /rhn/software/downloads/RetiredISOs.do

Comment 1 Máirín Duffy 2007-02-13 16:02:15 UTC
ah, channel_tree.js is still the old version so i can't check in the fix
(waiting on bug 207293, otherwise all of the old channel listviews will become
unusable)

attaching fixed channel_tree.js

Comment 2 Máirín Duffy 2007-02-13 16:02:49 UTC
Created attachment 147992 [details]
fixed channel_tree.js

Comment 3 Máirín Duffy 2007-02-13 16:03:27 UTC
Created attachment 147993 [details]
screenshot of the IE issue - the above proposed fixes should fix this

Comment 4 Grant Gainey 2007-02-21 13:18:55 UTC
I'm fixing this in 207293 - closing this one as a dup so we track in one place

*** This bug has been marked as a duplicate of 207293 ***


Note You need to log in before you can comment on or make changes to this bug.