Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228517 - ISE when viewing rhel5 GA kickstart file
Summary: ISE when viewing rhel5 GA kickstart file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Matthew Davis
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-13 15:22 UTC by Matthew Davis
Modified: 2007-10-30 02:01 UTC (History)
3 users (show)

Fixed In Version: rhn420
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-27 18:26:07 UTC


Attachments (Terms of Use)

Description Matthew Davis 2007-02-13 15:22:21 UTC
Description of problem:

The following exception occured while executing this request:
GET /rhn/kickstart/KickstartFileDownload.do

Date:2/13/07 10:14:31 AM EST
Headers:
  accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  accept-encoding: gzip,deflate
  accept-language: en-us,en;q=0.5
  connection: keep-alive
  cookie: JSESSIONID=8C9605886EBE810125FA8A902D6BAA5F;
s_vi=[CS]v1|45C9F142000025D3-A160B5E0000496A[CE];
rh_user=mdavis_rhn|Matthew|customer|;
rh_auth_token=1:1171379668xa69b6e4a2de493484ac3de0eb0aed52e;
pxt-session-cookie=73x9da76f9fa9e12f52cdbfa936280b076f
  host: fjs-0-09.rhndev.redhat.com
  keep-alive: 300
  referer: https://fjs-0-09.rhndev.redhat.com/rhn/kickstart/ActivationKeysSubmit.do
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070131
Fedora/1.5.0.9-2.fc6 Firefox/1.5.0.9 pango-text
  content-length: 0

Request:
Local Name = fjs-0-09.rhndev.redhat.com
Server Name = fjs-0-09.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session =
org.apache.catalina.session.StandardSessionFacade@38d5b19[session=StandardSession[8C9605886EBE810125FA8A902D6BAA5F]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = org.apache.struts.action.MESSAGE,
javax.servlet.jsp.jstl.fmt.timeZone.request, ksdata, kickstartDownloadForm,
session, __sitemesh__filterapplied, requestedUri,
org.apache.struts.action.mapping.instance, org.apache.struts.action.MODULE,


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException: Could not set null value for parameter: pid
        at
org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)   
         
        at
com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:70)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)        
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
       
        at
com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:136)      
         
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
       
        at
com.redhat.rhn.frontend.servlets.ContextFilter.doFilter(ContextFilter.java:98)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
       
        at
com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
       
        at
com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
        at
com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:52)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
       
        at
com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:88)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
       
        at
com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
        at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
        at
org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
        at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
        at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
        at java.lang.Thread.run(Thread.java:568)
Caused by: com.redhat.rhn.common.db.datasource.ParameterValueNotFoundException:
Could not set null value for parameter: pid
        at
com.redhat.rhn.common.db.datasource.CachedStatement.setupParamMap(CachedStatement.java:305)
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:335)
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:316)
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:244)
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:233)
        at
com.redhat.rhn.common.db.datasource.SelectMode.execute(SelectMode.java:100)
        at
com.redhat.rhn.manager.user.UserManager.verifyPackageAccess(UserManager.java:71)
        at
com.redhat.rhn.domain.rhnpackage.PackageFactory.lookupByIdAndUser(PackageFactory.java:97)
        at
com.redhat.rhn.manager.kickstart.KickstartFormatter.getFreshPackages(KickstartFormatter.java:678)
        at
com.redhat.rhn.manager.kickstart.KickstartFormatter.getRhnPost(KickstartFormatter.java:452)
        at
com.redhat.rhn.manager.kickstart.KickstartFileDownloadCommand.getFileData(KickstartFileDownloadCommand.java:57)
        at
com.redhat.rhn.frontend.action.kickstart.KickstartFileDownloadAction.setupFormValues(KickstartFileDownloadAction.java:55)
        at
com.redhat.rhn.frontend.action.kickstart.BaseKickstartEditAction.execute(BaseKickstartEditAction.java:66)
        at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)


More data in fjs-0-09.rhndev.redhat.com

Steps to Reproduce:
1. Create rhel5 kickstart profile 
2. Visit http://fjs-0-09.rhndev.redhat.com/kickstart/ks/label/<profile>

example:
http://fjs-0-09.rhndev.redhat.com/kickstart/ks/label/bare-5

Comment 13 Matthew Davis 2007-02-21 15:23:12 UTC
No ISE with viewing rhel5 kickstarts.


Note You need to log in before you can comment on or make changes to this bug.