Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228512 - RFE: (re)Add network card selection during startup
Summary: RFE: (re)Add network card selection during startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
: 225218 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-13 15:08 UTC by Gilboa Davara
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 20:23:18 UTC


Attachments (Terms of Use)

Description Gilboa Davara 2007-02-13 15:08:22 UTC
Description of problem:
In previous versions of RH/Fedora it was possible to select which network card
will be used for network installation during the "start networking" phase.
In F7, I'm forced to configure all the network cards. (Either using DHCP or by
assigning a static IP address)

Gilboa

Comment 1 David Cantrell 2007-02-13 15:25:17 UTC
Can you give more details?  You can still select the network interface in stage1
if you are doing a network-based install.  You will then only configure that
interface to fetch the stage2 image.

In stage2, it's different code that exists to configure the NICs for
post-install use.  Are you doing a text mode or graphical mode install (please
say graphical)?

Comment 2 Gilboa Davara 2007-02-13 16:00:47 UTC
My mistake.
- Stage I.
- Rescue mode.
- VMWare machine booting from an ISO image.

- Gilboa


Comment 3 Bill Nottingham 2007-03-02 17:46:15 UTC
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.

Comment 4 David Cantrell 2007-03-12 20:23:18 UTC
This has been fixed in rawhide in the text mode installer frontend.  In cases
where you only have one NIC, anaconda will ask if you want to configure that NIC
(yes/no).  With more than one NIC, you are presented with a list box and can
configure as many of the found NICs as you want.  Stay at this dialog box as
long as you want.  When you press OK, you advance to the next stage in the
installer.

Comment 5 David Cantrell 2007-03-12 20:24:04 UTC
*** Bug 225218 has been marked as a duplicate of this bug. ***

Comment 6 Gilboa Davara 2007-03-19 07:37:11 UTC
Thanks.


Note You need to log in before you can comment on or make changes to this bug.