Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228480 - Epiphany should hardcode $(libdir)/mozilla/plugins dir
Summary: Epiphany should hardcode $(libdir)/mozilla/plugins dir
Keywords:
Status: CLOSED DUPLICATE of bug 204547
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-13 10:43 UTC by Bastien Nocera
Modified: 2018-04-11 07:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-15 09:03:54 UTC


Attachments (Terms of Use)

Description Bastien Nocera 2007-02-13 10:43:07 UTC
In the firefox startup script:
if [ "$MOZ_PLUGIN_PATH" ]
then
 
MOZ_PLUGIN_PATH=$MOZ_PLUGIN_PATH:$MOZ_LIB_DIR/mozilla/plugins:$MOZ_DIST_BIN/plugins
else
  MOZ_PLUGIN_PATH=$MOZ_LIB_DIR/mozilla/plugins:$MOZ_DIST_BIN/plugins
fi
export MOZ_PLUGIN_PATH

Epiphany only looks in the plugins dir provided by the gecko engine, and its own
$(libdir)/epiphany/2.16/plugins/

It should also hardcode $(libdir)/mozilla/plugins

Comment 1 Bastien Nocera 2007-02-13 10:50:22 UTC
Actually, it already does, but hardcodes $(prefix)/lib, instead of using
$(libdir), which means it can't find 64-bit plugins on 64-bit platforms.

static void
mozilla_init_plugin_path ()
{
        const char *user_path;
        char *new_path;

        user_path = g_getenv ("MOZ_PLUGIN_PATH");
        new_path = g_strconcat (user_path ? user_path : "",
                                user_path ? ":" : "",
                                MOZILLA_PREFIX "/lib/mozilla/plugins"
                                ":" MOZILLA_HOME "/plugins",
#ifdef HAVE_PRIVATE_PLUGINS
                                ":" PLUGINDIR,
#endif
                                (char *) NULL);

        g_setenv ("MOZ_PLUGIN_PATH", new_path, TRUE);
        g_free (new_path);
}


Comment 2 Bastien Nocera 2007-02-13 10:57:58 UTC
Upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=407419

Comment 3 Bastien Nocera 2007-02-13 11:32:16 UTC
Patch tested, attached upstream.

Let me know whether I can push that to devel and fc6.

Comment 4 Bastien Nocera 2007-03-15 09:03:54 UTC

*** This bug has been marked as a duplicate of 204547 ***


Note You need to log in before you can comment on or make changes to this bug.