Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228451 - [gu_IN] Independent Vowel is treated as Dependent vowel (0A8C)
Summary: [gu_IN] Independent Vowel is treated as Dependent vowel (0A8C)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 228452
TreeView+ depends on / blocked
 
Reported: 2007-02-13 06:52 UTC by A S Alam
Modified: 2013-07-03 00:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-23 15:24:10 UTC


Attachments (Terms of Use)
Incorrect Image (deleted)
2007-02-13 06:52 UTC, A S Alam
no flags Details
correct image from Unicode (deleted)
2007-02-13 06:53 UTC, A S Alam
no flags Details
Patch for gu_IN independent Vowel sign (deleted)
2007-02-13 09:48 UTC, Sachin Tawniya
no flags Details | Diff

Description A S Alam 2007-02-13 06:52:52 UTC
Description of problem:
0A8C unicode of Gujarati treated as Dependent vowel in konqueror, kedit,
so shown Dotted circle before this,

Version-Release number of selected component (if applicable):
qt-3.3.7-2.fc7

How reproducible:
Everytime during type this

Steps to Reproduce:
1. open kedit/kate
2. with unicode input (rawcode with scim), type 0A8C
3. for copy paste this (เชŒ)
  
Actual results:
treated as Dependent Vowel (dotted circle before)

Expected results:
Independent vowel, so no DOtted cirecle before

Additional info:
check output of gedit

Images are attached

Comment 1 A S Alam 2007-02-13 06:52:52 UTC
Created attachment 147961 [details]
Incorrect Image

Comment 2 A S Alam 2007-02-13 06:53:26 UTC
Created attachment 147962 [details]
correct image from Unicode

Comment 3 Sachin Tawniya 2007-02-13 09:48:51 UTC
Created attachment 147967 [details]
Patch for gu_IN independent Vowel sign

Solved the issue. The script engine was reading 0A8C as Invalid script format.
Changed the entry in qscriptengine_x11.cpp. 
Thanks & regards,
Sachin

Comment 4 Ngo Than 2007-04-23 15:24:10 UTC
it's fixed in qt-3.3.8-5.fc7. Sachin, thanks for the fix.

Comment 5 Ngo Than 2007-04-23 15:44:43 UTC
*** Bug 228453 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.