Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228429 - mod_perl errantly provides perl(warnings)
Summary: mod_perl errantly provides perl(warnings)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mod_perl
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
: 243832 (view as bug list)
Depends On:
Blocks: mod_perl 243832
TreeView+ depends on / blocked
 
Reported: 2007-02-13 04:36 UTC by Chris Weyl
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.0.3-9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-12 15:06:50 UTC


Attachments (Terms of Use)

Description Chris Weyl 2007-02-13 04:36:28 UTC
The mod_perl package claims to provide perl(warnings), but warnings is a perl
pragma (and appropriately provided by the core perl package).  This provides
should be filtered out.

Comment 1 Joe Orton 2007-04-23 11:55:36 UTC
Thanks for the report.

Comment 2 Chris Weyl 2007-06-12 14:52:49 UTC
This problem persists in F-7, however it's not mod_perl-devel which provides
perl(warnings).

Comment 3 Chris Weyl 2007-06-12 15:06:50 UTC
Err -- rather, it _is_ mod_perl-devel, not the main mod_perl package, which
errantly provides perl(warnings).

mod_perl-devel-2.0.3-7.i386.rpm, in the F-7 release, has this bug.  However, -9,
in updates, doesn't.  Soo... it is fixed, but unlikely to help those installing
right off the bat.

Comment 4 Joe Orton 2007-06-18 15:49:11 UTC
*** Bug 243832 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.