Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228404 - NetworkManager does not check status of PPP/dial-up connections
Summary: NetworkManager does not check status of PPP/dial-up connections
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
: 208573 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-12 23:03 UTC by Kyle Gonzales
Modified: 2018-04-11 15:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-13 12:49:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 352325 None None None Never
GNOME Bugzilla 354068 None None None Never

Description Kyle Gonzales 2007-02-12 23:03:59 UTC
Description of problem:
When a dial-up/PPP connection is defined, then activated via NetworkManager,
NetworkManager does not check the status of the connection.  i.e. if the PPP
connection is initiated successful, this does not register in NetworkManager.

The problem is that, if you then need to activate vpnc or OpneVPN, you cannot do
so via NetworkManager.  Evolution and other apps are put into offline mode.


Version-Release number of selected component (if applicable):
NetworkManager-0.6.4-5.fc6

How reproducible:
Every time

Steps to Reproduce:
1.Define a dial-up or PPP connection via system-config-network
2.Activate the connection via NetworkManager
3.Allow it to connect.
  
Actual results:
NetworkManager says there is no network connection, even if PPP connection is
successful.

Expected results:
NetworkManager would show an activate network connection when PPP connection is
successful.

Additional info:
Also reported in bugzilla.gnome.org
#354068
#352325

Comment 1 Matěj Cepl 2007-02-13 12:49:20 UTC
Unfortunately, this is the most definitively bug which should be resolved
upstream. I would personally be very happy when this is fixed, but we all have
to wait before this is fixed by Gnome people.

Comment 2 Kyle Gonzales 2007-02-13 20:42:22 UTC
The problem I have with marking this as CLOSE UPSTREAM is that both of the bugs
attached to this bugzilla from bugzilla.gnome.org are assigned to Dan Williams,
who is a Red Hat employee.  So, it sure seems as if Red Hat will be the one
doing this work, and push it upstream...

However, I will work with Dan upstream to get this working.

Comment 3 Christopher Aillon 2007-02-13 20:50:46 UTC
All bugs go to Dan, who then might re-assign it to someone in the community if
they want to.  The point is not who does the work, but the process and Red Hat's
committment to community work.  Doing things in the community is an extremely
important part of being good open source people.  Apple and others have come
under major criticism for doing work internally and then pushing it back to the
community afterward so much that they are making headway into changing their
model to do things in the community first and then pull back.  This also has the
advantage of not duplicating or wasting e.g. Red Hat resources if the upstream
community decides the patch might be great for one distro but does not serve the
community needs and rejects the patch for any number of reasons, and uses a
different patch.  Maintenance then becomes harder, etc.   We don't want to
follow those footsteps.

Comment 4 Nicola Soranzo 2007-02-15 23:31:22 UTC
This bug is a duplicate of 208573, which is still in NEW status.

Comment 5 Matěj Cepl 2007-02-15 23:39:50 UTC
*** Bug 208573 has been marked as a duplicate of this bug. ***

Comment 6 Rod Nayfield 2007-02-28 02:34:09 UTC
The other issue this causes is with applications (gnome-y) that depend on
NetworkManager to tell it about network status. (dbus notification?)

For example, gaim will not connect to the network if you launch it when dialed
in via PPP.  It says "waiting for network" ...


Note You need to log in before you can comment on or make changes to this bug.