Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228361 - multi-lib conflicts
Summary: multi-lib conflicts
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-libs
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 175750 (view as bug list)
Depends On:
Blocks: FE7Target
TreeView+ depends on / blocked
 
Reported: 2007-02-12 20:01 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-13 13:47:53 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2007-02-12 20:01:35 UTC
gnome-libs - 1:1.4.2-3.fc6.x86_64
  Conflicts: 4
  File conflict in:
     /etc/mime-magic.dat
  Packages with the same files:
     gnome-libs - 1:1.4.2-3.fc6.i386

Comment 1 Paul Howarth 2007-02-13 09:25:20 UTC
I've just done this:

# ls -1 gnome* ORB* imlib* glib* gtk* libpng10*
glib-1.2.10-26.fc7.i386.rpm
glib-1.2.10-26.fc7.x86_64.rpm
glib-devel-1.2.10-26.fc7.i386.rpm
glib-devel-1.2.10-26.fc7.x86_64.rpm
gnome-libs-1.4.2-3.fc6.i386.rpm
gnome-libs-1.4.2-3.fc6.x86_64.rpm
gnome-libs-devel-1.4.2-3.fc6.i386.rpm
gnome-libs-devel-1.4.2-3.fc6.x86_64.rpm
gtk+-1.2.10-57.fc7.i386.rpm
gtk+-1.2.10-57.fc7.x86_64.rpm
gtk+-devel-1.2.10-57.fc7.i386.rpm
gtk+-devel-1.2.10-57.fc7.x86_64.rpm
imlib-1.9.13-31.fc7.i386.rpm
imlib-1.9.13-31.fc7.x86_64.rpm
imlib-devel-1.9.13-31.fc7.i386.rpm
imlib-devel-1.9.13-31.fc7.x86_64.rpm
libpng10-1.0.21-1.fc7.i386.rpm
libpng10-1.0.21-1.fc7.x86_64.rpm
libpng10-devel-1.0.21-1.fc7.i386.rpm
libpng10-devel-1.0.21-1.fc7.x86_64.rpm
ORBit-0.5.17-20.fc7.i386.rpm
ORBit-0.5.17-20.fc7.x86_64.rpm
ORBit-devel-0.5.17-20.fc7.i386.rpm
ORBit-devel-0.5.17-20.fc7.x86_64.rpm
# yum localinstall gnome* ORB* imlib* glib* gtk* libpng10*

and that succeeded on my FC6.x86_64 system (albeit with *lots* of .rpmnew files
in /etc/gtk from the config files in the gtk+ packages). I can see that
/etc/mime-magic.dat is different in the i386 and x86_64 packages but it doesn't
seem to upset rpm/yum on FC6. Is FC7 more sensitive to this?

As for a possible fix, how about %ghost-ing /etc/mime-magic.dat and generating
it from /etc/mime-magic in %post?

Your report says "Conflicts: 4"; what are the other conflicts?


Comment 2 Michael Schwendt 2007-02-13 09:58:16 UTC
/etc files create no conflict if they are marked %config.

The interesting question is why is mime-magic.dat a binary file?
Is it arch-independent? The differences in a hex-dump look quite big.
How is it accessed? And if both i386 and x86_64 gnome-libs are installed,
can the i386 code read the x86_64 mime-magic.dat and vice versa?

Comment 3 Paul Howarth 2007-02-13 11:59:22 UTC
I believe I have a fix for this now. The mime-magic.dat file is basically the
contents of a glib array dumped into a file. The elements of the array are not
zeroed out before they are set up, so parts not explicitly written to get
seemingly random values. Just adding a call to memset() at the top of the loop
that sets up the array results in identical files on i386 and x86_64.

Are there any other conflicts in this package or is it OK to commit this fix and
build new packages now?

Comment 4 Michael Schwendt 2007-02-13 12:19:37 UTC
No other files create a conflict.


Comment 5 Paul Howarth 2007-02-13 13:19:47 UTC
OK, should be fixed in gnome-libs-1.4.2-4.fc7 (should be in the needsign queue).

Comment 6 Michael Schwendt 2007-02-13 13:47:53 UTC
Confirmed.


Comment 7 Paul Howarth 2007-03-28 20:03:04 UTC
*** Bug 175750 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.