Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228359 - djvulibre multi-lib conflicts
Summary: djvulibre multi-lib conflicts
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: djvulibre
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-12 19:58 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-19 15:41:06 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2007-02-12 19:58:57 UTC
djvulibre - 3.5.18-1.fc7.x86_64
  Conflicts: 2
  File conflict in:
     /usr/share/man/man1/nsdejavu.1.gz
     /usr/share/man/ja/man1/nsdejavu.1.gz
  Packages with the same files:
     djvulibre - 3.5.18-1.fc7.i386

Comment 1 Matthias Saou 2007-02-13 10:04:21 UTC
Ouch. Is this really to be considered a bug? I really hope not...

Comment 2 Michael Schwendt 2007-02-13 10:45:15 UTC
djvulibre-devel.i386 makes available djvulibre.i386 on x86_64.

It's an EasyFix, though.


Comment 3 Matthias Saou 2007-02-13 11:06:00 UTC
EasyFix how? I thought rpm had all the hacks it needed to deal with typically
conflicting files like docs, translations and arch-specific binaries in this
kind of case. So if it reports a conflict, the man pages must differ between
arches, right? Is finding out why and finding a solution to make them identical
what you mean by EasyFix?

Maybe I shouldn't have split out the devel sub-package, and stay with the main
package providing it, since AFAIK nothing in Fedora builds against djvulibre
anyway, and the devel is only a few kBs...

Comment 4 Michael Schwendt 2007-02-13 11:20:56 UTC
Virtual -devel packages would be no different. All that matters is
that there is a -devel package.

The corresponding thread on fedora-devel-list says that conflicts in
%doc are common. When checking Rawhide, only six packages had a
multi-lib conflict left.

EasyFix, because a single instance of /usr/lib in the manual is
replaced with /usr/lib64. In all other places it still reads /usr/lib
or /usr/local/lib. And "netscape" in the path is inaccurate anyway,
since the file is packaged in a different location.

$ grep /usr/lib nsdejavu.1.x86_64 
.B /usr/lib64/netscape/plugins/nsdejavu.so
.B "/usr/lib/netscape/plugins/nsdejavu.so"
.B "ln -s /usr/lib/netscape/plugins/nsdejavu.so ."
.B "ln -s /usr/lib/netscape/plugins/nsdejavu.so ."
.IR /usr/lib/mozilla-1.1 :
.BI "cd " "/usr/lib/mozilla-1.1" "/plugins"
.B "ln -s /usr/lib/netscape/plugins/nsdejavu.so ."
.IR /usr/lib/mozilla-firefox :
.BI "cd " "/usr/lib/mozilla-firefox" "/plugins"
.B "ln -s /usr/lib/netscape/plugins/nsdejavu.so ."
.B "/usr/lib/netscape/plugins"

$ diff -u nsdejavu.1.i386 nsdejavu.1.x86_64 
--- nsdejavu.1.i386     2007-02-05 13:51:14.000000000 +0100
+++ nsdejavu.1.x86_64   2007-02-05 14:08:18.000000000 +0100
@@ -29,7 +29,7 @@
 nsdejavu \- DjVu browser plugin
 
 .SH SYNOPSIS
-.B /usr/lib/netscape/plugins/nsdejavu.so
+.B /usr/lib64/netscape/plugins/nsdejavu.so
 
 .SH DESCRIPTION
 The shared library

Comment 5 Matthias Saou 2007-02-13 12:08:11 UTC
Thanks for the information. I'll include a patch which updates the nsdejavu.1
man page quite a lot, and makes sure it's the same with different LIBDIR values,
as well as a quick one liner for the Japanese man page, since I don't read or
write Japanese...

Comment 6 Matthias Saou 2007-02-13 13:10:52 UTC
The patch is ready, but I'll only push a new build once I get bug #186801 fixed
too, since I'm now able to reproduce the problem myself.

Comment 7 Matthias Saou 2007-06-19 15:41:06 UTC
This has been fixed in Rawhide's 3.5.19-2.fc8 package.


Note You need to log in before you can comment on or make changes to this bug.