Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228329 - ed 0.3 causes rpmbuild to fail
Summary: ed 0.3 causes rpmbuild to fail
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: ed
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-12 18:00 UTC by Brian Collins
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-07 12:49:40 UTC


Attachments (Terms of Use)

Description Brian Collins 2007-02-12 18:00:09 UTC
Description of problem: rebuilding stock Postfix from source, the ed script
which modifies 'postfix-files' fails, causing rpmbuild to fail.  This is worked
around by installing older ed-0.2.

Version-Release number of selected component (if applicable): ed-0.3


How reproducible: easily

Steps to Reproduce:
1. download Postfix SRPM from any mirror site
2. have ed-0.3 installed
3. run 'rpmbuild --rebuild' on the Postfix SRPM package
  
Actual results:  During the RPM build, the following output occurs:
+ ed /var/tmp/postfix-buildroot/etc/postfix/postfix-files
17479
?
+ exit 1
error: Bad exit status from /var/tmp/rpm-tmp.62236 (%install)

Expected results:  An RPM build with an exit status of 0.


Additional info:  This may happen in other package builds as well, and in many
ed scripts.  This is the first I have run across it.

Comment 1 Karsten Hopp 2007-02-14 14:36:41 UTC
I've reported this upstream, testcase:
cat >> testfile << EOF
This is a test
EOF


with ed-0.2:
>ed testfile << EOF
> %s/test/dummy/
> w
> q
> EOF
40
42
>cat testfile
this is a failed test

with ed-0.3/0.4:
>ed testfile << EOF
> %s/test/dummy/
> w
> q
> EOF
40
?
>cat testfile
This is a test 

Comment 2 Karsten Hopp 2007-03-07 12:49:40 UTC
the upstream maintainer told me that '%' as a range is no longer valid range.
I think I'll revert to an older ed-version as the new one doesn't really fix
anything,it just causes problems with oder scripts. For now you can use '1,$'
instead of '%'.
See
http://lists.gnu.org/archive/html/bug-ed/2007-03/msg00000.html

Comment 3 Karsten Hopp 2007-03-14 13:31:49 UTC
can you please try ed-0.5 from rawhide ? The maintainer added support for '%'
ranges after he got some pressure from several sides.

Comment 4 Brian Collins 2007-03-19 02:51:03 UTC
Tried ed-0.5 from rawhide and it worked.


Note You need to log in before you can comment on or make changes to this bug.