Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228278 - Luci service should not start until after luci_admin init is run
Summary: Luci service should not start until after luci_admin init is run
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Stanko Kupcevic
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-12 14:18 UTC by Len DiMaggio
Modified: 2009-04-16 22:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-12 18:39:50 UTC


Attachments (Terms of Use)

Description Len DiMaggio 2007-02-12 14:18:04 UTC
Description of problem:
Luci service should not start until after luci_admin init is run

If the service is run before the 'luci_admin init' command is first run, an
error occurs. We should have the service fail to start, or return an error.

Version-Release number of selected component (if applicable):
luci-0.8-30.el5

How reproducible:
100%

Steps to Reproduce:
1. On a new install, start the luci service before first running luci_admin init -
2. Then access https://host:8084 - this error is returned:

The Luci server has not been initialized. To initialize it, log in in to the
server as root and run the command
luci_admin init

Actual results:
The above error

Expected results:
An error returned if the luci service is started before it has been initialized

Additional info:

Comment 1 Stanko Kupcevic 2007-02-12 18:39:50 UTC
This is an intended behavior. 

It was chosen with a premise that it is better to guide users thru
initialization ("initialize me" message), rather than making them debug the
problem (service failing to start). 

Closing as NOTABUG 



Note You need to log in before you can comment on or make changes to this bug.