Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228275 - resume hangs after suspend to RAM with message: lockdep: not fixing up alternatives
Summary: resume hangs after suspend to RAM with message: lockdep: not fixing up altern...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-12 14:05 UTC by David
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.6.20-1.2925.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-16 22:16:58 UTC


Attachments (Terms of Use)
entire /var/log/messages with possible useful info of harwdware (CPU...) (deleted)
2007-02-12 14:05 UTC, David
no flags Details

Description David 2007-02-12 14:05:01 UTC
Description of problem: see summary

Version-Release number of selected component (if applicable):
2.6.19-1.2895_1.fc6 and 2.6.20-1.2922.fc7

How reproducible: Always

Steps to Reproduce:
1. Suspend
2. Resume
  
Actual results:
system doesn't resume

Expected results:
system should resume normally

Additional info: relevant part from /var/log/messages

Feb 12 13:13:44 ananda NetworkManager: <information>	Going to sleep. 
Feb 12 13:13:47 ananda hidd[2493]: Exit
Feb 12 13:13:47 ananda sdpd[2401]: terminating...   
Feb 12 13:13:47 ananda hcid[2397]: Unregister path:/org/bluez
Feb 12 13:13:47 ananda hcid[2397]: Exit
Feb 12 13:13:47 ananda kernel: NET: Unregistered protocol family 31
Feb 12 13:13:49 ananda kernel: Disabling non-boot CPUs ...
Feb 12 13:13:49 ananda kernel: 
Feb 12 13:13:49 ananda kernel:
=======================================================
Feb 12 13:13:49 ananda kernel: [ INFO: possible circular locking dependency
detected ]
Feb 12 13:13:49 ananda kernel: 2.6.20-1.2922.fc7 #1
Feb 12 13:13:49 ananda kernel:
-------------------------------------------------------
Feb 12 13:13:49 ananda kernel: pm-suspend/3141 is trying to acquire lock:
Feb 12 13:13:49 ananda kernel:  (cpu_bitmask_lock){--..}, at: [<c0603d59>]
mutex_lock+0x21/0x24
Feb 12 13:13:49 ananda kernel: 
Feb 12 13:13:49 ananda kernel: but task is already holding lock:
Feb 12 13:13:49 ananda kernel:  (workqueue_mutex){--..}, at: [<c0603d59>]
mutex_lock+0x21/0x24
Feb 12 13:13:49 ananda kernel: 
Feb 12 13:13:49 ananda kernel: which lock already depends on the new lock.
Feb 12 13:13:49 ananda kernel: 
Feb 12 13:13:49 ananda kernel: 
Feb 12 13:13:49 ananda kernel: the existing dependency chain (in reverse order) is:
Feb 12 13:13:49 ananda kernel: 
Feb 12 13:13:49 ananda kernel: -> #3 (workqueue_mutex){--..}:
Feb 12 13:13:49 ananda kernel:        [<c0440754>] __lock_acquire+0x8dd/0xa04
Feb 12 13:13:49 ananda kernel:        [<c0440b64>] lock_acquire+0x56/0x6f
Feb 12 13:13:49 ananda kernel:        [<c0603bd3>] __mutex_lock_slowpath+0xe5/0x24a
Feb 12 13:13:49 ananda kernel:        [<c0603d59>] mutex_lock+0x21/0x24
Feb 12 13:13:49 ananda kernel:        [<c04358ca>] __create_workqueue+0x61/0x128
Feb 12 13:13:49 ananda kernel:        [<f8b3862f>]
cpufreq_governor_dbs+0xa1/0x30e [cpufreq_ondemand]
Feb 12 13:13:49 ananda kernel:        [<c0590751>] __cpufreq_governor+0x64/0x98
Feb 12 13:13:49 ananda kernel:        [<c059090c>] __cpufreq_set_policy+0x187/0x209
Feb 12 13:13:49 ananda kernel:        [<c0590b68>]
store_scaling_governor+0x164/0x1b1
Feb 12 13:13:49 ananda kernel:        [<c059002d>] store+0x37/0x48
Feb 12 13:13:49 ananda kernel:        [<c04b0b69>] sysfs_write_file+0xb8/0xe0
Feb 12 13:13:49 ananda kernel:        [<c0478c68>] vfs_write+0xaf/0x163
Feb 12 13:13:49 ananda kernel:        [<c04792b6>] sys_write+0x3d/0x61
Feb 12 13:13:49 ananda kernel:        [<c0404058>] syscall_call+0x7/0xb
Feb 12 13:13:49 ananda kernel:        [<ffffffff>] 0xffffffff
Feb 12 13:13:49 ananda kernel: 
Feb 12 13:13:49 ananda kernel: -> #2 (dbs_mutex){--..}:
Feb 12 13:13:49 ananda kernel:        [<c0440754>] __lock_acquire+0x8dd/0xa04
Feb 12 13:13:49 ananda kernel:        [<c0440b64>] lock_acquire+0x56/0x6f
Feb 12 13:13:49 ananda kernel:        [<c0603bd3>] __mutex_lock_slowpath+0xe5/0x24a
Feb 12 13:13:49 ananda kernel:        [<c0603d59>] mutex_lock+0x21/0x24
Feb 12 13:13:49 ananda kernel:        [<f8b38613>]
cpufreq_governor_dbs+0x85/0x30e [cpufreq_ondemand]
Feb 12 13:13:49 ananda kernel:        [<c0590751>] __cpufreq_governor+0x64/0x98
Feb 12 13:13:49 ananda kernel:        [<c059090c>] __cpufreq_set_policy+0x187/0x209
Feb 12 13:15:17 ananda syslogd 1.4.1: restart.

Comment 1 David 2007-02-12 14:05:01 UTC
Created attachment 147891 [details]
entire /var/log/messages with possible useful info of harwdware (CPU...)

Comment 2 David 2007-02-12 14:08:58 UTC
If I use kernel version 2.6.18-1.2869.fc6 or lower everything works perfectly
(suspend, hibernation).

Comment 3 Chuck Ebbert 2007-02-13 15:15:01 UTC
I am going to mark this a duplicate of bug 223604 even though they
are not exactly the same.  The cpufreq_ondemand driver needs to be
disabled during suspend/resume and that is not happening...

Please try the workaround reported in that bug.

*** This bug has been marked as a duplicate of 223604 ***

Comment 4 David 2007-02-14 15:56:37 UTC
I tried the workaround of bug 223604 but the problem remains (not resuming) and
now a message "lockdep: not fixing up alternatives." appears in the messages log.

When I try to resume, the hard disk starts working and after 1 or 2 seconds the
computer gets completely unresponsive, with CAPS LOCK led flashing and the
screen completely blank. I need to power off so that the system starts again.

Here are the relevant messages:

Feb 14 13:02:17 ananda NetworkManager: <information>	Going to sleep. 
Feb 14 13:02:20 ananda hidd[2465]: Exit
Feb 14 13:02:20 ananda sdpd[2376]: terminating...   
Feb 14 13:02:20 ananda hcid[2372]: Unregister path:/org/bluez
Feb 14 13:02:20 ananda hcid[2372]: Exit
Feb 14 13:02:20 ananda kernel: NET: Unregistered protocol family 31
Feb 14 13:02:22 ananda cpuspeed: Disabling ondemand cpu frequency scaling governor
Feb 14 13:02:22 ananda kernel: Disabling non-boot CPUs ...
Feb 14 13:02:22 ananda kernel: Breaking affinity for irq 1
Feb 14 13:02:22 ananda kernel: Breaking affinity for irq 14
Feb 14 13:02:22 ananda kernel: CPU 1 is now offline
Feb 14 13:02:22 ananda kernel: lockdep: not fixing up alternatives.
Feb 14 13:03:45 ananda syslogd 1.4.1: restart.

Comment 5 David 2007-03-16 22:16:58 UTC
This problem disappeared in new kernel: 2.6.20-1.2925.fc6


Note You need to log in before you can comment on or make changes to this bug.