Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228221 (anderson) - TBc3704fb6 config.py:656:_getsysver:TypeError: rpmdb open failed
Summary: TBc3704fb6 config.py:656:_getsysver:TypeError: rpmdb open failed
Keywords:
Status: CLOSED DUPLICATE of bug 213963
Alias: anderson
Product: Fedora
Classification: Fedora
Component: rpm
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-11 21:32 UTC by john anderson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-09 19:46:18 UTC


Attachments (Terms of Use)
bug dump (deleted)
2007-02-11 21:32 UTC, john anderson
no flags Details

Description john anderson 2007-02-11 21:32:35 UTC
Description of problem:
i get this error when i updated awhile back but it went away but still no
updates have succeded in installation even though it says it does i also get
this error message when i install an rpm

Version-Release number of selected component (if applicable):


How reproducible:
i think it happened when i did a shutdown after a update yum install didnt shutdown 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 john anderson 2007-02-11 21:32:35 UTC
Created attachment 147865 [details]
bug dump

Comment 2 Jeff Johnson 2007-02-12 12:46:07 UTC
Try doing
    rm -f /var/lib/rpm/__db*

Comment 3 Paul Nasrat 2007-03-13 11:07:45 UTC
Is this still occuring.

Comment 4 Panu Matilainen 2007-08-09 19:46:18 UTC
Most likely yet another kernel mmap() bug victim of the time. If reproducable
after updating to kernel 2.6.19-1.2895 or later then reinvestigation is needed.

*** This bug has been marked as a duplicate of 213963 ***


Note You need to log in before you can comment on or make changes to this bug.