Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228217 - /usr/bin/chkrootkit only runnable from console
Summary: /usr/bin/chkrootkit only runnable from console
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: chkrootkit
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 228220 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-11 20:03 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-11 21:43:18 UTC


Attachments (Terms of Use)

Description Need Real Name 2007-02-11 20:03:58 UTC
Description of problem:

Why is /usr/bin/chkrootkit linked to /usr/bin/consolehelper?

The result is that you can't run 'chkrootkit' unless you are on the console.
Furthermore, even if you are on the console, 'chkrootkit' won't run within a
'screen' (/usr/bin/screen)

chkrootkit is exactly one of those types of programs that one would like to run
remotely to check whether a server has been hacked.

Even worse, when you run chkrootkit remotely, it just exits quietly giving the
unknowing user no indication of what is going on. Now I know that you can
alternatively just run /usr/lib/chkrootkit-0.47/chkrootkit, but the unsuspecting
user wouldn't know that and would not understand why /usr/bin/chkrootkit is not
working when not on a console.

At a minimum, if not run from the console, it should return a message
instructing the user to either run it from the console or to run
/usr/lib/chkrootkit-0.47/chkrootkit directly.

Comment 1 Michael Schwendt 2007-02-11 21:00:42 UTC
What do you get when running "which chkrootkit"?


Comment 2 Need Real Name 2007-02-11 21:19:04 UTC
which chkrootkit gives: /usr/bin/chkrootkit

Comment 3 Need Real Name 2007-02-11 21:21:05 UTC
*** Bug 228220 has been marked as a duplicate of this bug. ***

Comment 4 Michael Schwendt 2007-02-11 21:43:18 UTC
Please become superuser before running chkrootkit. For the superuser
there is a working chkrootkit in /usr/sbin/chkrootkit. Concerning
your other troubles, look into X Forwarding.


Comment 5 Need Real Name 2007-02-12 03:08:55 UTC
OK. I have been using 'sudo' which still uses my regular path which prioritized
/usr/bin/chkrootkit first.
I hadn't realized that there was a version in /usr/sbin/chkrootkit but that
should solve my problems...

Thanks


Note You need to log in before you can comment on or make changes to this bug.