Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228203 - RFE: Include tunctl for creation of tap devices
Summary: RFE: Include tunctl for creation of tap devices
Keywords:
Status: CLOSED DUPLICATE of bug 453973
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL: http://www.user-mode-linux.org/cvs/*c...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-11 13:40 UTC by Till Maas
Modified: 2008-07-03 18:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-03 18:38:26 UTC


Attachments (Terms of Use)

Description Till Maas 2007-02-11 13:40:22 UTC
http://www.user-mode-linux.org/cvs/*checkout*/tools/tunctl/tunctl.c?rev=1.4

Please include tunctl in qemu because afaik it is the only way to use qemu with
tap? network interfaces without the need to run qemu as root. As root one can
create a tap device for a special user with tunctl that can be used by that user
in qemu.

Comment 1 David Woodhouse 2007-02-11 15:43:04 UTC
There are other packages which could do with tunctl. Actually it's probably
better off being combined into iproute2 and also having proper support for it
added to initscripts.

Comment 2 Till Maas 2007-06-28 17:21:55 UTC
Will it become part of iproute2 or be supported in initscripts any time soon? If
not, I am going to package it as an individual package.

Comment 3 Till Maas 2007-07-01 21:49:46 UTC
(In reply to comment #2)
> Will it become part of iproute2 or be supported in initscripts any time soon? If
> not, I am going to package it as an individual package.

I have a new idea. It seems I should be able to create a patch for ifup to
support Virtual Interfaces that are created with tunctl. Would you accept such a
patch given it is in a good shape? How are the chances to get this into Fedora
8, when I write this patch, soon?

Comment 4 Jon Stanley 2008-04-23 20:28:32 UTC
Adding FutureFeature keyword to RFE's.

Comment 6 Bill Nottingham 2008-07-03 18:38:26 UTC

*** This bug has been marked as a duplicate of 453973 ***


Note You need to log in before you can comment on or make changes to this bug.