Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228193 - Standalone djview displays pages very slowly
Summary: Standalone djview displays pages very slowly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: djvulibre
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-11 07:51 UTC by Emmanuel Kowalski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 3.5.18-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-13 09:33:24 UTC


Attachments (Terms of Use)

Description Emmanuel Kowalski 2007-02-11 07:51:19 UTC
Description of problem:
On my laptop (a recent Dell D820), the standalone djview displays djvu
files very slowly (up to 3 or 4 seconds per page). On the other hand, the
browser plugin displays the same files instantaneously (with Firefox).

Version-Release number of selected component (if applicable):
djvulibre-3.5.17-2.fc6.i386

How reproducible:
Always.

Steps to Reproduce:
1. Download a djvu file (e.g. 
http://archive.numdam.org/article/AIF_2000__50_3_833_0.djvu
)
2. View the file from the command line with djview.
3. Optionally, browse to see the same file.
  
Actual results:
Display is very slow in 2. and quite fast in 3.

Expected results:
The same speed whether using the standalone viewer or plugin.

Additional info:
The laptop has 2GB of Ram. The video card is an NVidia GeForce Go 7300
with 256 MB video memory, using the nv driver.

I compiled the 3.5.18 release from the src.rpm file on djvulibre.org,
and the resulting viewer does not have this issue.

Comment 1 Matthias Saou 2007-02-12 12:42:03 UTC
Since 3.5.18 has been working fine for me and for you, and since I've received
no bug reports regarding it, I've pushed the 3.5.18 update to FC-5 and FC-6.
Please let me know if those packages also fix that slowness issue.

Comment 2 Emmanuel Kowalski 2007-02-13 09:33:24 UTC
The new release djvulibre-3.5.18-1.fc6 resolves the problem.


Note You need to log in before you can comment on or make changes to this bug.