Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228191 - Return from VT switch very very bad (modesetting)
Summary: Return from VT switch very very bad (modesetting)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-11 07:31 UTC by Andrew Bartlett
Modified: 2018-04-11 11:35 UTC (History)
5 users (show)

Fixed In Version: xorg-x11-drv-i810-2.0.0-4.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-25 00:39:16 UTC


Attachments (Terms of Use)
Lifebook P7010 Xorg.0.log (deleted)
2007-02-18 06:19 UTC, Ilpo Nyyssonen
no flags Details

Description Andrew Bartlett 2007-02-11 07:31:05 UTC
This bug may well be closely related to Bug #228045

Description of problem:

Using i855GM, intel driver.

Low refersh rate on the LCD flat panel (laptop display).  I didn't even think
LCD's could flicker...

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-1.6.5-10.fc7
xorg-x11-server-Xorg-1.2.0-1.fc7

How reproducible:

Every time.

Steps to Reproduce:
1. Start X.
  
Actual results:

Low refresh flicker

Expected results:

Solid LCD goodness

Comment 1 Matěj Cepl 2007-02-12 10:00:39 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.


Comment 2 Ilpo Nyyssonen 2007-02-18 06:19:37 UTC
Created attachment 148278 [details]
Lifebook P7010 Xorg.0.log

I too can see this kind of effect.

Comment 3 Matěj Cepl 2007-02-27 20:46:08 UTC

*** This bug has been marked as a duplicate of 202476 ***

Comment 4 Bill Nottingham 2007-02-27 20:48:26 UTC
202476 is about text mode being scrambled on VT switch. This bug is about X
going haywire on return from VT switch.

Comment 5 Joachim Frieben 2007-03-23 19:46:45 UTC
Same here on a "DELL Optiplex 745" with 965Q onboard graphics. For both
"i810" and "intel" driver, switching from "X" to a virtual console and
back several times results in a black or a dark blue flickering display.
Even "ctrl-alt-bckspc" won't restore normal operation. One has to reboot
the system to obtain a working "X" environment again. This holds for the
latest packages, namely:

  xorg-x11-server-Xorg-1.2.99.902-1.fc7
  xorg-x11-drv-i810-1.6.5-14.fc7

According to the "README" file included in the source tarball there are
known issues with "VT" switching, but the cited bug report

  http://bugs.freedesktop.org/show_bug.cgi?id=5795

has been closed.

Comment 6 Jeff Norden 2007-04-04 00:03:48 UTC
I have the same problem with a Dell Optiplex 745, and can also get it to occur
on a system with a supermicro 965G based motherboard.

It also occurs with the Fedora 7 test 3 live CD's, both x86_64 and i386 versions
(on the Optiplex anyway, I haven't checked the supermicro system).

-Jeff



Comment 7 Tom London 2007-04-15 19:23:16 UTC
On Thinkpad X60, return from VT1->VT7 results in 'logout of graphical session'.
 That is, I get gdm greeter screen to login again.

I haven't noticed this running in 'i810' mode, just 'intel' mode.

Found this in /var/log/gdm/:0.log.1:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80d2041]
1: [0x8a9420]
2: /usr/bin/Xorg [0x80d8101]
3: /usr/bin/Xorg [0x80d85b5]
4: /usr/bin/Xorg(TraverseTree+0x1e) [0x807321e]
5: /usr/bin/Xorg(WalkTree+0x38) [0x80732a8]
6: /usr/bin/Xorg [0x80d8648]
7: /usr/lib/xorg/modules/extensions//libglx.so [0x9078fa]
8: /usr/bin/Xorg(xf86Wakeup+0x3bd) [0x80d375d]
9: /usr/bin/Xorg(WakeupHandler+0x59) [0x808d3f9]
10: /usr/bin/Xorg(WaitForSomething+0x1ae) [0x81b45ae]
11: /usr/bin/Xorg(Dispatch+0x8d) [0x80891ed]
12: /usr/bin/Xorg(main+0x495) [0x8071045]
13: /lib/libc.so.6(__libc_start_main+0xe0) [0x47af6ef0]
14: /usr/bin/Xorg(FontFileCompleteXLFD+0x1e5) [0x8070361]

Fatal server error:
Caught signal 11.  Server aborting



Comment 8 Joachim Frieben 2007-04-24 09:58:19 UTC
Upgrading to "xorg-x11-drv-i810-1.6.5-19.fc7" and setting the driver
to "intel" solves the issue completely for a "DELL Optiplex 745"
sporting a "965Q" onboard graphics.

Comment 9 Andrew Bartlett 2007-07-25 00:39:16 UTC
On xorg-x11-drv-i810-2.0.0-4.fc7 I'm not seeing this (and I've not seen this for
quite a while now), so let's close this out. 


Note You need to log in before you can comment on or make changes to this bug.