Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228182 - Azureus cannot re-check large files
Summary: Azureus cannot re-check large files
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: azureus
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anthony Green
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-11 02:20 UTC by Michel Alexandre Salim
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-11 21:32:21 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2007-02-11 02:20:18 UTC
Description of problem:
When instructing Azureus to force re-check a large torrent that's already
downloaded, it failed with an OOM error

Version-Release number of selected component (if applicable):
2.5.0.0-11.fc7

How reproducible:
Always

Steps to Reproduce:
1. Start a torrent for a reasonably large file
2. When done, force re-check
  
Actual results:
"Disk read error - OutOfMemoryError" after slightly less than 10MB (5.6% of a
172.90MB file)

Expected results:
No OOM error

Additional info:
Upstream Azureus does not have this problem on Fedora Core 6. I cannot currently
run the upstream version with Sun JVM since all SWT applications refused to run

Comment 1 Anthony Green 2007-11-11 21:32:21 UTC
This bug is a gcj bug.  Fedora 8 includes IcedTea.  I'm going to close this with
WONTFIX now that we have a nice Free Software java.


Note You need to log in before you can comment on or make changes to this bug.