Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228179 - firefox has lost ability to select folder to add bookmark
Summary: firefox has lost ability to select folder to add bookmark
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-11 00:31 UTC by Doug Maxey
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-11 00:38:20 UTC


Attachments (Terms of Use)

Description Doug Maxey 2007-02-11 00:31:14 UTC
Description of problem:
In firefox you can no longer select a folder to drop a bookmark into.  

I don't do this real often, and think this just occured with the last update.
The first symptom noticed that CTRL-D dialog "save in other folder" button on
the right of the title box only adds "Create new folder" button to the "save
bookmark" dialog.  I expect that button to open a list of current folders, but
that does not happen.

As a workaround attempt, I opened the Bookmarks > Manage Bookmarks.  The dialog
opened, but had no files or folders listed.  I have a fairly substantial
bookmark file (which should be trimmed I guess), but it was viewable earlier
this week while I was editing some keywords.

Version-Release number of selected component (if applicable):
$ sudo grep firefox /var/log/yum.log
Dec 22 15:09:30 Updated: firefox.i386 1.5.0.9-1.fc6
Dec 22 15:10:52 Updated: firefox-devel.i386 1.5.0.9-1.fc6
Feb 08 04:05:35 Updated: firefox.i386 1.5.0.9-2.fc6
Feb 08 04:06:50 Updated: firefox-devel.i386 1.5.0.9-2.fc6


How reproducible: 100%


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
 ll -Z ~/.mozilla/firefox/default.ody/
-rw-r--r--  dwm dwm root:object_r:file_t             64397357.s
drwx------  dwm dwm user_u:object_r:file_t           bookmarkbackups/
-rw-------  dwm dwm root:object_r:file_t             bookmarks-20050505.html
-rw-------  dwm dwm user_u:object_r:user_home_t      bookmarks.bak
-rw-------  dwm dwm user_u:object_r:user_home_t      bookmarks.html

ll ~/.mozilla/firefox/default.ody/
total 12640
-rw-r--r--  1 dwm dwm   51354 Feb  3 21:27 64397357.s
drwx------  2 dwm dwm    4096 Feb  7 18:44 bookmarkbackups/
-rw-------  1 dwm dwm  281920 May  5  2005 bookmarks-20050505.html
-rw-------  1 dwm dwm  591853 Feb 10 18:06 bookmarks.bak
-rw-------  1 dwm dwm  591853 Feb 10 18:06 bookmarks.html

Comment 1 Doug Maxey 2007-02-11 00:38:20 UTC
Heh.  Stopped and restarted firefox, and behold.  Works.  Am pretty sure though
that I restarted the desktop since the last update.  Oh well.



Note You need to log in before you can comment on or make changes to this bug.