Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228146 - gnomad2 crashes on start
Summary: gnomad2 crashes on start
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnomad2
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Linus Walleij
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-10 14:19 UTC by jouni
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.8.11-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-13 16:01:53 UTC


Attachments (Terms of Use)

Description jouni 2007-02-10 14:19:46 UTC
Description of problem:
When trying to start gnomad2 it segfaults.

Version-Release number of selected component (if applicable):
gnomad2-2.8.11-1.fc6
libmtp-0.1.3-1.fc6

How reproducible:
Every time

Steps to Reproduce:
1.  start 'gnomad2' on console
2.
3.
  
Actual results:
Segmentation fault.  (with -D1 I get this:)
$ gnomad2 -D1
Enter view_and_sort_list_store(0)...
Enter view_and_sort_list_store(2)...
Adding dir entry: , size 3792142
Adding dir entry: , size 3547218
Adding dir entry: , size 3482852
Adding dir entry: , size 3558921
Adding dir entry: , size 0
Adding dir entry: , size 3030621
Adding dir entry: , size 3199058
Adding dir entry: , size 3947205
Getting metadata for: . (1/8)

Segmentation fault






Expected results:
Program starting

Additional info:
Used to work before  (Tried last time about four weeks ago...)
Sometimes a windows shows briefly on screen.  Too briefly to see what is on it.

Last lines on strace without device connected to USB:
read(3, "\1\0\2\1\0\0\0\0\0\0\0\0\4\0\0\0\10\0\0\0\0\0\0\0\0\0\0"..., 32) = 32
mmap2(NULL, 10489856, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb32b1000
mprotect(0xb32b1000, 4096, PROT_NONE)   = 0
clone(child_stack=0xb3cb14b4,
flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND|CLONE_THREAD|CLONE_SYSVSEM|CLONE_SETTLS|CLONE_PARENT_SETTID|CLONE_CHILD_CLEARTID,
parent_tidptr=0xb3cb1bd8, {entry_number:6, base_addr:0xb3cb1b90, limit:1048575,
seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0,
useable:1}, child_tidptr=0xb3cb1bd8) = 27201
futex(0x45eed7f8, FUTEX_WAKE, 1)        = 9
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Process 27200 detached

(with -f option:
[pid 27213] stat64("Something in my home dir", {st_mode=S_IFDIR|0700,
st_size=4096, ...}) = 0
[pid 27213] getdents(6, /* 0 entries */, 4096) = 0
[pid 27213] close(6)                    = 0
[pid 27213] --- SIGSEGV (Segmentation fault) @ 0 (0) ---
Process 27213 detached
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Process 27212 detached

Comment 1 Linus Walleij 2007-02-11 17:46:14 UTC
Hm, weird. I get the same thing, but only on the packages built with
RH builders! If I build from source this doesn't happen!

Comment 2 Linus Walleij 2007-02-11 23:00:50 UTC
I found that g_stat() misbehaves when linked to in RH build system
for some reason (still no idea why) so reverted to using just stat()
and submitted builds for 2.8.11-2 please tell me if this fixes your
problem!

Comment 3 jouni 2007-02-13 15:30:46 UTC
Verified the new version.  Works perfectly.  Thanks!

A bit talkative though when run from console - just a minor thing.

Comment 4 Linus Walleij 2007-02-13 16:01:53 UTC
OK closing, will fix the printf():s someday or atleast when
gnomad2 2.8.12 comes out.


Note You need to log in before you can comment on or make changes to this bug.