Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228134 - it doesnt provide shared libs,
Summary: it doesnt provide shared libs,
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hdf
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 222042
TreeView+ depends on / blocked
 
Reported: 2007-02-10 04:05 UTC by Balint Cristian
Modified: 2009-03-23 02:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-22 15:54:52 UTC


Attachments (Terms of Use)

Description Balint Cristian 2007-02-10 04:05:18 UTC
Description of problem:
doesnt provide shared libs.

Version-Release number of selected component (if applicable):
hdf-devel-4.2r1-11

How reproducible:
-

Steps to Reproduce:
1.-

  
Actual results:
-

Expected results:
-

Additional info:
   Please update library to ship shared libs too. 
   This block bug 222042, gdal cannot be builded.

Comment 1 Patrice Dumas 2007-02-10 10:09:26 UTC
gdal should be buildable with static or share libs.

I don't think it is wise to ship shared libs when upstream
don't, since the soname upstream chose may be different. In other
words, if you want shared libs support in HDF4 you should talk
to upstream and ask them.

Comment 2 Orion Poplawski 2007-02-12 17:38:59 UTC
I see no idication that gdal cannot be built against statics libs.

Comment 3 Balint Cristian 2007-02-22 15:54:52 UTC
ok. workarounded gdal.

Comment 4 Terje Røsten 2009-02-16 18:56:45 UTC
Hi Orion,

new release which seems like support for shared libs is out.

Please have a look here:

 ftp://ftp.hdfgroup.org/HDF/HDF_Current/src/RELEASE-4.2r4.txt


Read it all, it's some Fedora hints there.

Comment 5 Orion Poplawski 2009-03-02 22:05:11 UTC
Two big problems:

- C and Fortran in the same library.  Adds a dependency on libgfortran for all users of libdf.
- Install uses rpaths.  Very hard to strip out.

Still will wait until these are fixed upstream.

Comment 6 Terje Røsten 2009-03-22 18:06:05 UTC
Ok, I see, reopen the bug to watch it?

Comment 7 Orion Poplawski 2009-03-23 02:24:27 UTC
I'd rather not.  It will happen if/when upstream deals with it.


Note You need to log in before you can comment on or make changes to this bug.