Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228059 - Intel sound cards on 4.5 kernel beta may panic system on boot
Summary: Intel sound cards on 4.5 kernel beta may panic system on boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jason Baron
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-09 19:31 UTC by Jason Baron
Modified: 2013-03-06 05:59 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-08 04:50:17 UTC


Attachments (Terms of Use)
patch to fix the problem (deleted)
2007-02-09 19:31 UTC, Jason Baron
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0304 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 5 2007-04-28 18:58:50 UTC

Description Jason Baron 2007-02-09 19:31:20 UTC
Description of problem:

on 4.5 beta system with and intel audio sound card may panic on boot.
Specifically, i have model 82801G(ICH7) on a new kentsfield system.

Version-Release number of selected component (if applicable):

reproduces on 2.6.9-46.EL

How reproducible:

boot the box

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Unable to handle kernel NULL pointer dereference at 0000000000000000 RIP:
<ffffffffa0148193>{:snd_hda_codec:snd_hda_input_mux_info+16}
PML4 729b5067 PGD 76a8b067 PMD 0
Oops: 0000 [1] SMP
CPU 0
Modules linked in: md5 ipv6 parport_pc lp parport autofs4 i2c_dev i2c_core
sunrpc ds yenta_dPid: 3649, comm: alsactl Not tainted 2.6.9-45.ELsmp
RIP: 0010:[<ffffffffa0148193>]
<ffffffffa0148193>{:snd_hda_codec:snd_hda_input_mux_info+16}
RSP: 0018:000001007292fb58  EFLAGS: 00010206
RAX: 000001007fdd4400 RBX: 000001007f19c2c0 RCX: 0000000000000000
RDX: 000001007f19c2c0 RSI: 000001007292fc28 RDI: 0000000000000000
RBP: 000001007fdd4d68 R08: 0000000000000000 R09: 0000000000000000
R10: 0000000000000000 R11: 0000000000000000 R12: 000001007292fc28
R13: 0000007fbffff2e0 R14: 000001007fdd4c00 R15: 000001007736b780
FS:  0000002a95e05140(0000) GS:ffffffff804ed500(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000000000000000 CR3: 0000000000101000 CR4: 00000000000006e0
Process alsactl (pid: 3649, threadinfo 000001007292e000, task 0000010076b507f0)
Stack: 0000000000000000 ffffffffa00fcb2f 00000005db3863a8 00000100746ee030
       0000010002142760 0000000000000000 000001007292fbb8 ffffffff80132a8f
       0000000000000002 0000010002142760
Call Trace:<ffffffffa00fcb2f>{:snd:snd_ctl_ioctl+1180}
<ffffffff80132a8f>{activate_task+124
       <ffffffff801d22ec>{avc_has_perm+70} <ffffffff8016a65a>{do_no_page+1712}
       <ffffffff801d5632>{selinux_file_ioctl+711}
<ffffffff801eba95>{__up_read+16}       <ffffffff801247e9>{do_page_fault+577}
<ffffffff801ee1b5>{strncpy_from_user+74}
       <ffffffff8018bbc5>{sys_ioctl+853} <ffffffff8011026a>{system_call+126}


Code: 8b 07 49 89 f8 89 46 50 8b 17 48 8d 7e 58 8b 46 54 8d 4a ff
RIP <ffffffffa0148193>{:snd_hda_codec:snd_hda_input_mux_info+16} RSP
<000001007292fb58>
CR2: 0000000000000000
 <0>Kernel panic - not syncing: Oops


Expected results:

no panic

Additional info:

Comment 1 Jason Baron 2007-02-09 19:31:20 UTC
Created attachment 147797 [details]
patch to fix the problem

Comment 2 Jason Baron 2007-02-09 19:33:00 UTC
Also worth noting is that no sound comes out of the box on either U4 or U5 with
the patch mentioned in comment #1. This patch is being proposed as a temporary
solution. Upstream kernles produce sound, but this would require a more
extensive backport to get working properly.

Comment 3 Jason Baron 2007-02-23 22:25:24 UTC
This system booted fine on U4, while U5 panics the system on boot.

Comment 4 RHEL Product and Program Management 2007-02-23 23:05:27 UTC
Since Keyword Regression exists, this is a blocker,
not an exception.  Cleared exception flag.
Set blocker flag."

Comment 5 RHEL Product and Program Management 2007-02-26 21:03:26 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Jason Baron 2007-02-27 20:23:02 UTC
committed in stream U5 build 49. A test kernel with this patch is available from
http://people.redhat.com/~jbaron/rhel4/


Comment 11 Red Hat Bugzilla 2007-05-08 04:50:17 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html


Note You need to log in before you can comment on or make changes to this bug.