Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228053 - pycairo rpm is missing auto dependencies on some libraries
Summary: pycairo rpm is missing auto dependencies on some libraries
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: pycairo
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-09 19:15 UTC by Thomas Vander Stichele
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-16 19:36:27 UTC


Attachments (Terms of Use)

Description Thomas Vander Stichele 2007-02-09 19:15:09 UTC
Description of problem:

pycairo does not automatically pull in packages for libfontconfig and libXau. 
Maybe it is missing some more.



Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
[thomas@clocktime pitivi]$ mach -r f6g64 yum install pycairo
Setting up Install Process
Setting up repositories
core                                                                 [1/8]
gst-0.10-apps                                                        [2/8]
gst-0.10-deps                                                        [3/8]
local.fedora-6-x86_64-gstreamer                                      [4/8]
local.fedora-6-x86_64-gst 100% |=========================|  951 B    00:00     
livna                                                                [5/8]
updates                                                              [6/8]
gst-0.10-gst                                                         [7/8]
extras                                                               [8/8]
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package pycairo.x86_64 0:1.2.6-1.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 pycairo                 x86_64     1.2.6-1.fc6      updates            28 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         
Total download size: 28 k
Downloading Packages:
Running Transaction Test
warning: pycairo-1.2.6-1.fc6: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: pycairo                      ######################### [1/1] 

Installed: pycairo.x86_64 0:1.2.6-1.fc6
Complete!
[thomas@clocktime pitivi]$ mach -r f6g64 -k chroot
Entering /var/lib/mach/roots/fedora-6-x86_64-gstreamer, type exit to leave.
ERROR: ld.so: object '/usr/lib64/libselinux-mach.so' from LD_PRELOAD cannot be
preloaded: ignored.
-bash-3.1# python
Python 2.4.4 (#1, Oct 23 2006, 13:58:18) 
[GCC 4.1.1 20061011 (Red Hat 4.1.1-30)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import cairo
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib64/python2.4/site-packages/cairo/__init__.py", line 1, in ?
    from _cairo import *
ImportError: libfontconfig.so.1: cannot open shared object file: No such file or
directory
>>> 
-bash-3.1# logout
[thomas@clocktime pitivi]$ mach -r f6g64 yum install -y fontconfig
Setting up Install Process
Setting up repositories
core                                                                 [1/8]
gst-0.10-apps                                                        [2/8]
gst-0.10-deps                                                        [3/8]
local.fedora-6-x86_64-gstreamer                                      [4/8]
local.fedora-6-x86_64-gst 100% |=========================|  951 B    00:00     
livna                                                                [5/8]
updates                                                              [6/8]
gst-0.10-gst                                                         [7/8]
extras                                                               [8/8]
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package fontconfig.x86_64 0:2.4.1-3.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 fontconfig              x86_64     2.4.1-3.fc6      core              176 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         
Total download size: 176 k
Downloading Packages:
Running Transaction Test
warning: fontconfig-2.4.1-3.fc6: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: fontconfig                   ######################### [1/1] 
ERROR: ld.so: object '/usr/lib64/libselinux-mach.so' from LD_PRELOAD cannot be
preloaded: ignored.
ERROR: ld.so: object '/usr/lib64/libselinux-mach.so' from LD_PRELOAD cannot be
preloaded: ignored.
ERROR: ld.so: object '/usr/lib64/libselinux-mach.so' from LD_PRELOAD cannot be
preloaded: ignored.
ERROR: ld.so: object '/usr/lib64/libselinux-mach.so' from LD_PRELOAD cannot be
preloaded: ignored.
ERROR: ld.so: object '/usr/lib64/libselinux-mach.so' from LD_PRELOAD cannot be
preloaded: ignored.

Installed: fontconfig.x86_64 0:2.4.1-3.fc6
Complete!
[thomas@clocktime pitivi]$ mach -r f6g64 -k chroot
Entering /var/lib/mach/roots/fedora-6-x86_64-gstreamer, type exit to leave.
ERROR: ld.so: object '/usr/lib64/libselinux-mach.so' from LD_PRELOAD cannot be
preloaded: ignored.
-bash-3.1# python
Python 2.4.4 (#1, Oct 23 2006, 13:58:18) 
[GCC 4.1.1 20061011 (Red Hat 4.1.1-30)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import cairo
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib64/python2.4/site-packages/cairo/__init__.py", line 1, in ?
    from _cairo import *
ImportError: libXau.so.6: cannot open shared object file: No such file or directory
>>> 
-bash-3.1# ldd /usr/lib64/python2.4/site-packages/cairo/_cairo.so 
        libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00002aaaaacc7000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaaaf2e000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00002aaaab27c000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00002aaaab491000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00002aaaab715000)
        libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00002aaaab949000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00002aaaabb6e000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00002aaaabd77000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aaaac082000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
        libexpat.so.0 => /lib64/libexpat.so.0 (0x00002aaaac306000)
        libXau.so.6 => not found
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00002aaaac528000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaac72e000)
-bash-3.1#

Comment 1 Matthew Barnes 2007-02-15 02:34:21 UTC
Hmm, pycairo requires cairo.

$ rpm -q --requires cairo
...
libX11.so.6  
...
libfontconfig.so.1  
...

$ rpm -q --requires libX11
...
libXau.so.6
...

I'm not seeing the where the dependencies are broken.

Comment 2 Thomas Vander Stichele 2007-03-12 17:07:19 UTC
It's possible yum is doing it wrong.  Have you tried reproducing it with the
instructions I gave above ?

Comment 3 Matthew Miller 2007-04-10 16:35:13 UTC
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.

Comment 4 Christopher Aillon 2007-04-16 19:36:27 UTC
Sounds like something's messed up on your system.  pycairo requires cairo which
should bring in the other dependencies.  I can't reproduce either, and there's
nothing we could do really to fix it since the dependencies are already correct
in the spec file....


Note You need to log in before you can comment on or make changes to this bug.