Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228045 - Return from VT switch very very bad (modesetting)
Summary: Return from VT switch very very bad (modesetting)
Keywords:
Status: CLOSED DUPLICATE of bug 202476
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-09 18:13 UTC by Bill Nottingham
Modified: 2018-04-11 10:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-27 20:45:57 UTC


Attachments (Terms of Use)
X log (deleted)
2007-02-09 18:15 UTC, Bill Nottingham
no flags Details
xorg conf file (deleted)
2007-02-09 18:16 UTC, Bill Nottingham
no flags Details
probably useless video capture (deleted)
2007-02-09 18:56 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2007-02-09 18:13:21 UTC
Description of problem:

Using i965, intel driver.

When returning from a switch to a VT, X goes nutso.

Will try and dig up a movie, but the thought process is:
"Wow, that's screwy."
"This is probably bad for epileptics."
"It's like it lost vertical/horizontal hold on a old analog TV."
"I didn't know you could *do* that with a LCD."

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-1.6.5-11.fc7
xorg-x11-server-Xorg-1.2.0-5.fc7

How reproducible:

Every time.

Steps to Reproduce:
1. Start X.
2. Switch to a VC.
3. Switch back.
  
Actual results:

Melty vibrating crazy chaos.

Comment 1 Bill Nottingham 2007-02-09 18:15:21 UTC
Created attachment 147789 [details]
X log

Comment 2 Bill Nottingham 2007-02-09 18:16:15 UTC
Created attachment 147790 [details]
xorg conf file

Comment 3 Bill Nottingham 2007-02-09 18:56:50 UTC
Created attachment 147795 [details]
probably useless video capture

Here's some awful video of it. Yay for crappy cell phones.

Comment 4 Andrew Bartlett 2007-02-09 20:09:49 UTC
On my i855GM (on a Dell Latitude X300), I get similar results, but only on the
VT, switching back to X makes things good again.

Comment 6 Matěj Cepl 2007-02-27 20:45:57 UTC

*** This bug has been marked as a duplicate of 202476 ***


Note You need to log in before you can comment on or make changes to this bug.