Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2280 - funny package requirements
Summary: funny package requirements
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 3878 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-20 03:07 UTC by Jay Freeman
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-22 18:26:27 UTC


Attachments (Terms of Use)

Description Jay Freeman 1999-04-20 03:07:53 UTC
root(2)@ironclad Raw]# rpm -Uhv linuxconf-*1.14r4-3.i386.rpm
error: failed dependencies:
        redhat-release   is needed by linuxconf-1.14r4-3

redhat-release isn't on the rawhide server.  I remember a
couple weeks ago when I first installed rawhide the
installation had failed on redhat-release since the file
wasn't there, but I had assumed that was because this was
rawhide, and the redhat-release was left in the packages to
install list by accident (not a worry to me since I saw
rawhide-release be installed).

Comment 1 Bill Nottingham 1999-04-20 05:56:59 UTC
this is fixed in a later rawhide-release package. :)

Comment 2 Jay Freeman 1999-05-05 22:08:59 UTC
OK, I figured part of the problem out, it seems that linuxconf has to
be installed WITH rawhide-release (as in at the same time, after is a
no go) for it to install properly.  Here is what I did earlier:

[root(3)@ironclad RPMs]# rpm -Uhv rawhide-release-1.3.5-1.noarch.rpm
rawhide-release
##################################################
[root(3)@ironclad RPMs]# rpm -Uhv linuxconf*-1.14r4-4.i386.rpm
error: failed dependencies:
        redhat-release   is needed by linuxconf-1.14r4-4
[root(3)@ironclad RPMs]# rpm -q --whatprovides redhat-release
rawhide-release-1.3.5-1
[root(3)@ironclad RPMs]# rpm -e rawhide-release
[root(3)@ironclad RPMs]# inst linuxconf*-1.14r4-4.i386.rpm rawhide-
release-1.3.5-1.noarch.rpm
rawhide-release
##################################################
warning: /etc/conf.linuxconf created as /etc/conf.linuxconf.rpmnew
linuxconf
##################################################
linuxconf-devel
##################################################
[root(3)@ironclad RPMs]#

Comment 3 Jay Freeman 1999-05-05 22:12:59 UTC
OUCH, and get THIS:

[root(4)@ironclad /etc]# rpm -V linuxconf
Unsatisfied dependencies for linuxconf-1.14r4-4: redhat-release
.M...... c /etc/conf.linuxconf
<took really long time and cancelled at this point>

Comment 4 Cristian Gafton 1999-06-16 15:08:59 UTC
assigned to notting. rawhide-reklese should obsolete and provide
redhat-release (based on versions numbers...)

Comment 5 Bill Nottingham 1999-06-23 22:23:59 UTC
you can't do that with the current version of RPM; you can
only provide 'redhat-release', not 'redhat-release = some-version'.

Comment 6 Bill Nottingham 1999-07-06 15:03:59 UTC
*** Bug 3878 has been marked as a duplicate of this bug. ***

error: failed dependencies:
        redhat-release   is needed by linuxconf-1.14r4-4
 rawhide-release-1.4.2-1.noarch.rpm
linuxconf-1.14r4-4.i386.rpm

Comment 7 Bill Nottingham 1999-07-13 22:06:59 UTC
Actually, it seems to be an RPM problem.

linuxconf *prerequires* redhat-release (no version).
rawhide-release provides redhat-release, but this
isn't satisfying the dependency. Jeff, any ideas?

Comment 8 Jeff Johnson 1999-07-22 18:26:59 UTC
The linuxconf prereq prevented the dependency from being resolved
by the provides in rawhide-release.

rpm-3.0.3-0.7 with versioned provides support should fix this problem.


Note You need to log in before you can comment on or make changes to this bug.