Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227984 - gweled creates enormous music.raw file
Summary: gweled creates enormous music.raw file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gweled
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thorsten Leemhuis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-09 11:06 UTC by Jon Burgess
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version: gweled-0.7-7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-24 12:48:07 UTC


Attachments (Terms of Use)

Description Jon Burgess 2007-02-09 11:06:22 UTC
Description of problem:
Running gweled generates a music.raw file which keeps growing at a rapid rate
eating up disk space.

Version-Release number of selected component (if applicable):
gweled-0.7-6.fc6.x86_64

How reproducible:
every time

Steps to Reproduce:
1. run gweled
2. look at size of music.raw file in current directory
3. 
  
Actual results:
$ ls -l music.raw
-rw------- 1 jburgess jburgess 1744785408 Feb  9 00:35 music.raw


Expected results:
No file!

Additional info:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=401727

The problem and fix:
   "Gweled registers all drivers including DISK WRITER drivers, I have
removed RegisterAll and manually register all drivers which makes sense
(AudioFile, ESD, ALSA, OSS and NoSound).... Disable disk writer driver in MikMod
initialization"

Comment 1 Thorsten Leemhuis 2007-02-09 19:06:05 UTC
I don't see the problem locally -- that's odd, but well, software is odd sometimes. 

I contacted upstream about the issue. I'll probably apply the debian patch to my
package in case upstream has no plans for a new release in the near future.

Comment 2 Jon Burgess 2007-02-09 19:33:00 UTC
Looks like it falls back to the disk writer after other options fail. 
strace shows...

access("/dev/sound/dsp", F_OK)          = -1 ENOENT (No such file or directory)
access("/dev/dsp0", F_OK)               = -1 ENOENT (No such file or directory)
open("/dev/dsp", O_WRONLY)              = -1 EBUSY (Device or resource busy)
stat("music.raw", 0x7fff5b8c6bd0)       = -1 ENOENT (No such file or directory)
open("music.raw", O_RDWR|O_CREAT|O_TRUNC, 0600) = 16

I'm using KDE so artsd has the alsa sound devices open already:
[root@shark ~]# lsof -c artsd | grep /dev
artsd   18024 jburgess  mem    CHR              116,8               8023
/dev/snd/pcmC0D0p
artsd   18024 jburgess    0r   CHR                1,3               1883 /dev/null
artsd   18024 jburgess    9r   CHR              116,2               6927
/dev/snd/timer
artsd   18024 jburgess   10u   CHR              116,8               8023
/dev/snd/pcmC0D0p

Looking at the documented driver support in MikMod suggests that it doesn't
support artsd (but does support alsa, oss etc). If I kill artsd then the sound
in gweled works and no music.raw file is created.

Comment 3 Thorsten Leemhuis 2007-02-24 12:48:07 UTC
No answer from upstream; I applied to patches from debian to the devel and FC-6
branch and requested a build.


Note You need to log in before you can comment on or make changes to this bug.