Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227979 - Pup gui looks like it hung
Summary: Pup gui looks like it hung
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-02-09 09:30 UTC by David Nielsen
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 20:47:05 UTC


Attachments (Terms of Use)
to show debug output of pirut/pup crash. (deleted)
2007-03-03 22:04 UTC, Gaillard Lee Johnson
no flags Details

Description David Nielsen 2007-02-09 09:30:27 UTC
Description of problem:
When you update the system using pup the window goes all grey as if crashed,
this tends to freak users out. In casual conversation with users this is the one
aspect they hate the most about Fedora, by far. 

The bug also applies to FC6.

Version-Release number of selected component (if applicable):
pirut-1.2.10-1.fc7

How reproducible:
100%

Steps to Reproduce:
1. Use pup to update
  
Actual results:
the update works but the UI looks like it hung

Expected results:
Nicely updated UI to show progress and assure users that their lovely Fedora is
not broken.

Additional info:

Comment 1 Peter Gordon 2007-03-03 06:24:12 UTC
Same here. I clicked "Apply updates" and the window went gray; then nearly 10
minutes later the progress dialog of "Downloading packages..." showed up. It's
very disconcerting and a bit disheartening if you don't my saying so.

Comment 2 Gaillard Lee Johnson 2007-03-03 22:04:23 UTC
Created attachment 149192 [details]
to show debug output of pirut/pup crash.

This is the debug save from pirut crash, but a very similar error happens when
running either pirut or pup.

Comment 3 Jeremy Katz 2007-04-09 20:47:05 UTC
This should be better with pirut 1.3.5 and yum 3.1.6 


Note You need to log in before you can comment on or make changes to this bug.