Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227936 - system-config-printer unhappy when setting a default printer
Summary: system-config-printer unhappy when setting a default printer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2007-02-08 23:16 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.7.52-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-15 09:55:18 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2007-02-08 23:16:33 UTC
Description of problem:

Pushing "Make Default Printer" button in "Settings" tab of
configurator resulted in:

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 1080,
in on_btnPMakeDefault_clicked
    if e != cups.HTTP_NOT_FOUND:
UnboundLocalError: local variable 'e' referenced before assignment

This was consistent in subsequent tries until exit.

That printer is a network located printer using built-in JetDirect server,
and Samsung ML-2250 pxlmono driver.

The queue in question is currently the only one so this happens
to be not a big issue in this configuration.  Morever it appears
that the operation actually succeeded because I see in printers.conf
"DefaultPrinter" tag and after a restart "State" says: "This is
the default printer" (but this is the only one).

Version-Release number of selected component (if applicable):
system-config-printer-0.7.50-1.fc7

How reproducible:
see above

Comment 1 Tim Waugh 2007-02-09 10:00:26 UTC
Fixed in CVS.  Thanks for the report!

Comment 2 Tim Waugh 2007-02-09 16:16:12 UTC
Fixed in 0.7.51-1.fc7 for devel.


Comment 3 Tim Waugh 2007-02-13 13:23:28 UTC
FC6 test update: 0.7.52-1.fc6.

Comment 4 Fedora Update System 2007-02-14 20:00:32 UTC
Fixed in update: system-config-printer-0.7.52-1.fc6


Note You need to log in before you can comment on or make changes to this bug.