Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227906 - problem starting prelude-manager
Summary: problem starting prelude-manager
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: prelude-manager
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thorsten Scherf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 230606 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-08 20:58 UTC by Gonz
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.9.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-02 18:51:56 UTC


Attachments (Terms of Use)

Description Gonz 2007-02-08 20:58:56 UTC
Description of problem: 
prelude-manager will not start


Version-Release number of selected component (if applicable):
libprelude-0.9.12.1-1.fc6
libprelude-devel-0.9.12.1-1.fc6
libprelude-perl-0.9.12.1-1.fc6
libprelude-python-0.9.12.1-1.fc6
gnutls-devel-1.4.1-2
pcre-devel-6.6-1.1

mysql-server-5.0.27-1.fc6
mysql-devel-5.0.27-1.fc6

libpreludedb-0.9.11.1-2.fc6
libpreludedb-devel-0.9.11.1-2.fc6
libpreludedb-mysql-0.9.11.1-2.fc6
libpreludedb-perl-0.9.11.1-2.fc6
libpreludedb-python-0.9.11.1-2.fc6

prelude-manager-0.9.7.1-3.fc6
prelude-manager-db-plugin-0.9.7.1-3.fc6
prelude-manager-devel-0.9.7.1-3.fc6
prelude-manager-xml-plugin-0.9.7.1-3.fc6

prelude-lml-0.9.8.1-5.fc6

prewikka-0.9.8-1.fc6
python-cheetah-2.0-0.2.rc7.fc6

How reproducible:
install libprelude packages, then mysql packages configure database according to 
instruction on https://trac.prelude-ids.org/wiki/InstallingLibpreludedb .

then install prelude-mangers packages, edit
/etc/prelude-manager/prelude-manager.conf [db] section 

add prelude-manager profile
prelude-adduser add prelude-manager --uid 0 --gid 0

install prelude-lml package

register sensor 
prelude-adduser register prelude-lml "idmef:w admin:r" <manager address>


Steps to Reproduce:
1.after installing packages and described above
2. run prelude-manager
3. 
  
Actual results:
- Subscribing Normalize to active decoding plugins.
- server started (listening on 127.0.0.1 port 4690).
- Subscribing db[default] to active reporting plugins.
idmef-message-scheduler.c:idmef_message_scheduler_init:749: could not open
/var/spool/prelude-manager/scheduler: No such file or directory.
prelude-manager.c:main:229: couldn't initialize alert scheduler.

Expected results:


Additional info:

Comment 1 Thorsten Scherf 2007-02-09 08:05:50 UTC
fixed in latest version (prelude-manager-0.9.7.1-4.fc6).

could you verify that it works!?

Comment 2 Gonz 2007-02-15 20:43:29 UTC
that fixed it

Comment 3 Thorsten Scherf 2007-06-02 18:44:30 UTC
*** Bug 230606 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.