Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227902 - Cannot compile postfix
Summary: Cannot compile postfix
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
: 239964 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-08 20:51 UTC by Luis Marqueta
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-22 11:26:43 UTC


Attachments (Terms of Use)

Description Luis Marqueta 2007-02-08 20:51:44 UTC
Description of problem: Cannot compile postfix


Version-Release number of selected component (if applicable): postfix-2.3.3-2


How reproducible:
Always: compile postfix using provided specfile

Steps to Reproduce:
1. Install postfix SRPM
2. rpmbuild -ba postfix.spec
3.
  
Actual results:

+ install -c -m 755 man/man1/smtp-source.1
/var/tmp/postfix-buildroot/usr/share/man/man1/
+ ed /var/tmp/postfix-buildroot/etc/postfix/postfix-files
17479
?
+ exit 1
error: Bad exit status from /var/tmp/rpm-tmp.42063 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.42063 (%install)


Expected results:
postfix compiled

Additional info:
The following fix works for me:

--- postfix.spec.sed    2007-02-08 21:50:53.000000000 +0100
+++ postfix.spec.orig   2007-02-08 21:50:09.000000000 +0100
@@ -262,8 +262,12 @@ done
 # RPM compresses man pages automatically.
 # - Edit postfix-files to reflect this, so post-install won't get confused
 #   when called during package installation.
-sed -i 's/\(\/man[158]\/.*\.[158]\):/\1.gz:/'
$RPM_BUILD_ROOT%{postfix_config_dir}/postfix-files
-sed -i 's/\$config_directory\/aliases:f/\#/'
$RPM_BUILD_ROOT%{postfix_config_dir}/postfix-files
+ed $RPM_BUILD_ROOT%{postfix_config_dir}/postfix-files <<EOF || exit 1
+%s/\(\/man[158]\/.*\.[158]\):/\1.gz:/
+%s/\$config_directory\/aliases:f/\#/
+w
+q
+EOF

Comment 1 David J Craigon 2007-03-28 16:03:23 UTC
Me too. I am running x86_64

Comment 2 David J Craigon 2007-03-29 09:17:01 UTC
The development (rawhide) RPM does build OK though, but the configuration files
end up in the wrong place. But that's probably a separate bug.

Comment 3 Thomas Woerner 2007-09-24 15:13:22 UTC
*** Bug 239964 has been marked as a duplicate of this bug. ***

Comment 4 Thomas Woerner 2007-10-04 15:57:15 UTC
Please have a look at postfix-2.4.5-2.fc6 in FC-6-testing.

Comment 5 Thomas Woerner 2007-11-22 11:26:43 UTC
Fixed in package postfix-2.4.5-2.fc6 in FC-6-updates.


Note You need to log in before you can comment on or make changes to this bug.