Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2279 - x11amp dumps core on first level 3 mp3 file played
Summary: x11amp dumps core on first level 3 mp3 file played
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: x11amp
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-20 02:07 UTC by David Miller
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-24 19:39:25 UTC


Attachments (Terms of Use)

Description David Miller 1999-04-20 02:07:53 UTC
Make sure you have no .x11amp directory in your home
directory.  Invoke x11amp and select a level 3 mp3
file to play, it will dump core.

The problem is that x11amp is not setting itself up
correctly with various defaults if no ~/.x11amp/config
file exists.

So if you start x11amp, and then exit it, x11amp will
create a default ~/.x11amp/config file and this problem
goes away for all future invocations.

The core happens because the mpg123 library is being
passed a null pointer for the ip3_format argument in
function mpg123.c:eval_id3_format.

Comment 1 Bill Nottingham 1999-05-24 19:39:59 UTC
seems to have been fixed in 0.9_beta1.1


Note You need to log in before you can comment on or make changes to this bug.