Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227874 - No device/cpu data on some machines
Summary: No device/cpu data on some machines
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: smolt
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike McGrath
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-08 18:22 UTC by David Rees
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.9.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-03 17:38:12 UTC


Attachments (Terms of Use)
machine1.txt (deleted)
2007-02-08 18:22 UTC, David Rees
no flags Details
machine2.txt (deleted)
2007-02-08 18:23 UTC, David Rees
no flags Details
machine3.txt (deleted)
2007-02-08 18:24 UTC, David Rees
no flags Details

Description David Rees 2007-02-08 18:22:29 UTC
Description of problem:
smolt does not report any device data for some machines. Some errors are
generated (which vary slightly on the affected machines).

Version-Release number of selected component (if applicable):
smolt-0.7-1.fc6

How reproducible:
Every time.

Steps to Reproduce:
1. Run smoltSendProfile
  
Actual results:
I have 3 machines that differ slightly in output. I'll attach the output from
each (after removing the UUID). But the common errors generated by each is below:

Error reading hardware information: dbus_bindings.DBusException
Error reading DMI information: dbus_bindings.DBusException

Expected results:
Expect to see a device list and proper CPU information.

Comment 1 David Rees 2007-02-08 18:22:30 UTC
Created attachment 147686 [details]
machine1.txt

Comment 2 David Rees 2007-02-08 18:23:25 UTC
Created attachment 147687 [details]
machine2.txt

Comment 3 David Rees 2007-02-08 18:24:08 UTC
Created attachment 147688 [details]
machine3.txt

Comment 4 Mike McGrath 2007-02-08 19:07:59 UTC
I'm currently in the process of re-writing the dbus bindings for smolt, would
you be willing to be a test subject when the time comes?

Comment 5 David Rees 2007-02-08 19:10:24 UTC
Yep, I can help with any testing you need.

Comment 6 David Rees 2007-02-14 20:12:31 UTC
I see that smolt-0.8-1.fc6 was released. On one system I got the following stack
trace because messagebus wasn't running:

Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 60, in ?
    profile = smolt.Hardware()
  File "/usr/share/smolt/client/smolt.py", line 158, in __init__
    systemBus = dbus.SystemBus()
  File "/usr/lib/python2.4/site-packages/dbus/_dbus.py", line 260, in __new__
    return Bus.__new__(cls, Bus.TYPE_SYSTEM, use_default_mainloop, private)
  File "/usr/lib/python2.4/site-packages/dbus/_dbus.py", line 99, in __new__
    bus._connection = dbus_bindings.bus_get(bus_type, private)
  File "dbus_bindings.pyx", line 1692, in dbus_bindings.bus_get
dbus_bindings.DBusException: Failed to connect to socket
/var/run/dbus/system_bus_socket: No such file or directory

After I started up messagebus, I got this stack trace:

Introspect error: The name org.freedesktop.Hal was not provided by any .service
files
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 60, in ?
    profile = smolt.Hardware()
  File "/usr/share/smolt/client/smolt.py", line 160, in __init__
    all_dev_lst = mgr.GetAllDevices()
  File "/usr/lib/python2.4/site-packages/dbus/proxies.py", line 25, in __call__
    ret = self._proxy_method (*args, **keywords)
  File "/usr/lib/python2.4/site-packages/dbus/proxies.py", line 102, in __call__
    reply_message = self._connection.send_with_reply_and_block(message, timeout)
  File "dbus_bindings.pyx", line 455, in
dbus_bindings.Connection.send_with_reply_and_block
dbus_bindings.DBusException: The name org.freedesktop.Hal was not provided by
any .service files


Comment 7 Mike McGrath 2007-02-14 20:38:38 UTC
Is hal running?

/etc/init.d/haldaemon status

I need to add a more graceful error.

Comment 8 David Rees 2007-02-14 21:07:37 UTC
Much better.

I agree, printing a better error message for when messagebus and haldaemon
aren't running would be a perfect way to fix this issue.

Comment 9 Jared Smith 2007-03-03 17:13:18 UTC
I'm seeing something similar, but slightly different.  I get the following error:

Send this information to the Smolt server? (y/n) y
Transmitting ...
Server Message: "Critical: Device Read Failed -
4388|0|None|None|ieee1394|Unknown|None|Unknown (0x001124)"


Comment 10 Mike McGrath 2007-03-03 17:38:12 UTC
Should be fixed now.


Note You need to log in before you can comment on or make changes to this bug.