Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227849 - IPv6: Badness in dst_release at include/net/dst.h:149
Summary: IPv6: Badness in dst_release at include/net/dst.h:149
Keywords:
Status: CLOSED DUPLICATE of bug 167715
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Neil Horman
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-08 15:42 UTC by Per Steinar Iversen
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-26 15:51:27 UTC


Attachments (Terms of Use)
Kernel log after problem occurs (deleted)
2007-02-08 15:42 UTC, Per Steinar Iversen
no flags Details
dmesg output with dst_badness messages (deleted)
2007-02-08 22:48 UTC, Tim Mooney
no flags Details

Description Per Steinar Iversen 2007-02-08 15:42:52 UTC
Description of problem:

Kernel starts complaining about
"Badness in dst_release at include/net/dst.h:149"

Version-Release number of selected component (if applicable):

kernel-smp-2.6.9-42.0.8.EL.x86_64

How reproducible:

Not possible to reproduce but happens every few weeks.

Steps to Reproduce:
1. Run linux, in this case a mailserver using both IPv4 and IPv6.
2. Eventually the kernel starts complaining and sendmail seems to have problems.
3. A reboot cures everything, until next time.
  
Actual results:

Sometimes the kernel has problems that seems to be IPv6 related. See attached
logfile.

Expected results:

No problems!

Additional info:

The machine is a Dell PowerEdge 1950.

Comment 1 Per Steinar Iversen 2007-02-08 15:42:52 UTC
Created attachment 147657 [details]
Kernel log after problem occurs

Comment 2 Tim Mooney 2007-02-08 22:47:42 UTC
We just had this problem happen today on a couple of our RHEL4 boxes too, though
they're both running a slightly older kernel (2.6.9-42.0.3.ELsmp).  The dmesg
messages corresponded with periods of extremely high load.

Our kernel messages don't look exactly the same, so I'll attach ours too.




Comment 3 Tim Mooney 2007-02-08 22:48:44 UTC
Created attachment 147712 [details]
dmesg output with dst_badness messages

Comment 4 Neil Horman 2007-03-01 20:27:31 UTC
would you all mind please sending in sysreports?  That would help track down
where the extra refcount decrement might be.  Thanks!

Comment 5 Per Steinar Iversen 2007-03-02 08:25:58 UTC
The output of sysreport in this case is large (33MB) and contains a complete
configuration for the system in question - is the idea to attach this in public
to this bugreport?

Comment 6 Neil Horman 2007-03-02 14:52:07 UTC
yes, thats the idea.  If you don't feel comfortable doing so, you can email them
to me instead.

Comment 7 Alexander Boström 2007-04-24 08:06:00 UTC
Is this related to bug #167715 in any way?


Comment 8 Per Steinar Iversen 2007-04-26 15:31:48 UTC
It looks a lot like that to me. When is a fixed kernel going to appear?

Comment 9 Neil Horman 2007-04-26 15:51:27 UTC
Looks like it will be released with the 4.6 kernel update

*** This bug has been marked as a duplicate of 167715 ***


Note You need to log in before you can comment on or make changes to this bug.