Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227845 - cpuspeed daemons cannot start
Summary: cpuspeed daemons cannot start
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-utils
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jarod Wilson
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On: 184469
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-08 15:20 UTC by Linda Wang
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-09 13:28:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Jarod Wilson 2007-02-08 15:36:10 UTC
+++ This bug was initially created as a clone of Bug #184469 +++

I'm fairly confident the cpuspeed initscript is operating as intended here. The
heart of the issue is that cpuspeed is installed by default and chkconfig'd on
for all systems. Since we have no way of knowing ahead of time if the system
actually supports frequency scaling or not, we opt to fail to start up silently
to avoid alarming anyone. These appear to be simple cases of cpuspeed silently
exiting because the systems they're being run on in this case don't support cpu
frequency scaling.

Folks are welcome to post their /proc/cpuinfo and dmesg output after booting
with cpufreq.debug=7 added to their kernel boot params to try to convince me
otherwise though. :)

Comment 2 RHEL Product and Program Management 2007-05-09 07:49:32 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Jarod Wilson 2007-05-09 13:28:31 UTC
3mo. w/o any feedback contrary to my assertion that cpuspeed is operating as
intended, closing NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.