Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227844 - Beryl-core not built with XGL
Summary: Beryl-core not built with XGL
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: beryl-core
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-08 15:11 UTC by Kenny Root
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-08 15:37:53 UTC


Attachments (Terms of Use)

Description Kenny Root 2007-02-08 15:11:36 UTC
Description of problem:
the new version of beryl-core is not built with --enable-xgl flag thereby
rendering it unusable with XGL.

Version-Release number of selected component (if applicable):
0.1.9999.1-2.fc6

How reproducible:
Every try

Steps to Reproduce:
1. Install and configure server using fglrx and XGL
2. Install previous version of beryl-core (0.1.99)
3. Run beryl-xgl --replace and test effects.
4. Upgrade to 0.1.9999.1 and notice that beryl-xgl is gone.
5. Notice that beryl --force-xgl fails because of fglrx and mesa problem
  
Actual results:
beryl-xgl not found and beryl --force-xgl not a replacement

Expected results:
beryl-xgl executes during start-up

Additional info:
$ beryl --force-xgl --replace
**************************************************************
* Beryl system compatiblity check                            *
**************************************************************

Detected xserver                                : XGL

Checking Display :0.0 ...

Checking for XComposite extension               : passed (v0.3)
Checking for XDamage extension                  : passed
Checking for RandR extension                    : passed
Checking for XSync extension                    : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig                  : passed
Checking for GLX_EXT_texture_from_pixmap        : passed
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Checking for non power of two texture support   : failed

Comment 1 Jarod Wilson 2007-02-08 15:37:53 UTC
Upstream changing things around on me yet again... New build coming soon.


Note You need to log in before you can comment on or make changes to this bug.