Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227804 - anaconda fails to build on updated FC6 system
Summary: anaconda fails to build on updated FC6 system
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-08 10:28 UTC by Moritz Baumann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-08 15:23:55 UTC


Attachments (Terms of Use)

Description Moritz Baumann 2007-02-08 10:28:50 UTC
Description of problem:
Anaconda after yum upgrade not rebuildable anymore.
can be rebuild on a fresh installed FC6.
after a yum -y upgrade
rpmbuild --rebuild anaconda-11.1.1.3-1.src.rpm
fails.

Version-Release number of selected component (if applicable):
11.1.1.3.-1

How reproducible:
always.

Steps to Reproduce:
1. rpmdev-setuptree
2. cd rpmbuild/SRPMS
3. yumdownloader -e core-source --source anaconda
4. rpmbuild --rebuild anaconda-11.1.1.3-1.src.rpm
5. <fix missing dependencies for rpmbuild>
6. rpmbuild --rebuild anaconda-11.1.1.3-1.src.rpm


  
Actual results:
...
make[2]: Leaving directory
`/home/baumanmo/rpmbuild/BUILD/anaconda-11.1.1.3/isys/gzlib'
cc -c -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -Wall -Werror -D_GNU_SOURCE=1
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE=1 -D_LARGEFILE64_SOURCE=1
-DUSESELINUX=1 -I/usr/include/python2.4 -I.. -DHAVE_NFS -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -I/usr/include/libdhcp -I/usr/include/dhcp4client
-I/usr/include/dhcp6client   -fPIC -o isys.lo isys.c
isys.c: In function 'doRaidStart':
isys.c:974: error: 'START_ARRAY' undeclared (first use in this function)
isys.c:974: error: (Each undeclared identifier is reported only once
isys.c:974: error: for each function it appears in.)


Expected results:
the actual files in 
rpmbuild/RPMS/i386

Additional info:
# cd /usr/include
# grep -R START_ARRAY *
linux/raid/md_u.h:/*  0x31 was START_ARRAY  */
linux/raid/md_u.h:#define RESTART_ARRAY_RW      _IO (MD_MAJOR, 0x34)
seems the header files changed.

After changing rpmbuild/BUILD/isys/isysc.c (line 974)
START_ARRAY to RUN_ARRAY and doing a "make in that dir I get:
cc -c -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Werror
-D_GNU_SOURCE=1 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE=1
-D_LARGEFILE64_SOURCE=1 -DUSESELINUX=1 -I/usr/include/python2.4 -I.. -DHAVE_NFS
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -I/usr/include/libdhcp
-I/usr/include/dhcp4client -I/usr/include/dhcp6client   -fPIC -o wireless.lo
wireless.c
In file included from wireless.c:29:
/usr/include/linux/wireless.h:649: error: expected specifier-qualifier-list
before ‘__s32’
/usr/include/linux/wireless.h:662: error: expected specifier-qualifier-list
before ‘__u16’
/usr/include/linux/wireless.h:676: error: expected specifier-qualifier-list
before ‘__s32’
...

Comment 1 David Cantrell 2007-02-08 15:23:55 UTC
The version of anaconda that shipped with FC-6 will build with the kernel that
shipped with FC-6.  The ones that have landed in FC-6 updates have changed the
header files, so the FC-6 anaconda won't rebuild correctly.

This has been fixed in anaconda CVS and is available in the rawhide anaconda.

Marking this as NOTABUG because we don't guarantee that the anaconda in release
versions will continue to build with all the updates.  If you want to work on
anaconda source trees, pull from CVS or get the source RPMS from rawhide.


Note You need to log in before you can comment on or make changes to this bug.