Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227762 - Backtrace on invalid repository
Summary: Backtrace on invalid repository
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-07 23:06 UTC by Andrew Bartlett
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-23 20:10:41 UTC


Attachments (Terms of Use)
Anaconda exception backtrace (deleted)
2007-02-07 23:06 UTC, Andrew Bartlett
no flags Details

Description Andrew Bartlett 2007-02-07 23:06:33 UTC
Description of problem:
When manually entering an external repository, if the URL is syntaxtily valid,
but incorrect, ananconda faults

Version-Release number of selected component (if applicable):


How reproducible:
only tried once

Steps to Reproduce:
1. Install (I installed from PXE boot to a HTTP exported mounted DVD tree)
2. Select an additional repository 
3. Enter URL with an invalid path component

http://mirror.internode.on.net/pub/fedora/linux/development/extras/i386 instead of
http://mirror.internode.on.net/pub/fedora/linux/extras/development/i386

Actual results:
warns about an invalid group file (no package selections), but permits
installaction to proceed to the backtrace (to be attached)

Expected results:
Installation should simply warn that the repository is invalid, and refuse to
proceed

Additional info:

Comment 1 Andrew Bartlett 2007-02-07 23:06:33 UTC
Created attachment 147610 [details]
Anaconda exception backtrace

Comment 2 Chris Lumens 2007-02-23 20:10:41 UTC
This was only a problem because you were going back to the task selection screen
from the confirmation screen.  This will be fixed in the next build of anaconda.
 Thanks for the report.

Comment 3 Bill Nottingham 2007-03-02 17:42:27 UTC
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.


Note You need to log in before you can comment on or make changes to this bug.