Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227745 - CD boot loader doesn't detect macbook's keyboard
Summary: CD boot loader doesn't detect macbook's keyboard
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: syslinux
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Brock Organ
URL:
Whiteboard: bzcl34nup
: 238354 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-07 21:55 UTC by Ra P.
Modified: 2008-05-07 01:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-07 01:08:45 UTC


Attachments (Terms of Use)

Description Ra P. 2007-02-07 21:55:51 UTC
Hi

if I run fedora core 7 test1 live cd x86 on a macbook core 2 duo, the keyboard
isn't usable until the kernel has booted, i.e. it doesn't work in grub. I've
tried ubuntu feisty (development) herd3 and this also happens.

Steps to reproduce:
1. press c on macbook startup.
2. boot from live cd
3. grub doesn't detect the keyboard and you can't change the kernel live
cd boots.

workaround:
4. let the cd start, and once gdm has started the keyboard works.
5. reboot.
6. the keyboard works on grub

this bug has also been reported in ubuntu bug tracker:
https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/79172

thanks

Comment 1 Andrew Cathrow 2007-02-08 23:00:05 UTC
I wonder if this is related to the MacBook's BIOS(/EFI layer)
On the Core 2 Duo's it's easily reproducable.

This doesn't just happen on Live CD's it also happens with grub once the OS is
installed.
However this doesn't happen 100% of the time - I'd say that 3/4 of the time the
keyboard doesn't work in grub, I've not managed to work out the exact steps that
allow the keyboard to work.

Plugging in an external keyboard works but - you must plugin the USB keyboard
AFTER grub starts - not before.

This happens with and without rEFIt intall.ed

Comment 2 Bill Nottingham 2007-03-02 17:44:02 UTC
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.

Comment 3 Ra P. 2007-03-12 09:01:29 UTC
this also happens on fedora core 6. I thought reporting on the lastest
development snapshot was more correct.

Comment 4 Michael Wiktowy 2007-04-26 18:58:05 UTC
This problem is not limited to MacBooks. I see the same thing happening on a
Dell Precision 690 Workstation. If I am using a USB keyboard, you cannot switch
option in the bootloader for the LiveCD 7 test4. If you use a PS2 keyboard, it
works fine.

Also, the keyboard works fine with the BIOS since I can use it to select all the
options needed to boot from CD. So keyboard operation and connectivity through a
USB hub and plugged directly into the machine have all been verified and all do
not work with the bootloader.

Comment 5 Jeremy Katz 2007-05-01 20:26:13 UTC
*** Bug 238354 has been marked as a duplicate of this bug. ***

Comment 6 Ra P. 2007-06-09 12:00:13 UTC
Hi

this bug still happens on fedora 7 live x86

thanks

Comment 7 Ra P. 2007-06-18 20:33:31 UTC

Hi again

Good news is that mephis 6.5 64bits boot loader (I think it's a customized grub)
doesn't suffer this bug. Can someone look into mephis changes?

thanks


Comment 8 Ra P. 2007-07-21 11:42:11 UTC
Any new on this?

Comment 9 Michael Wiktowy 2007-08-28 23:34:55 UTC
I know that it is still a problem with my Dell Precision 690 Workstation using
F8test1 LiveCD.

PS2 keyboard works fine, USB keyboard does not.

The workaround in the original bug report doesn't work for me though. Always
dead once grub pops up but does work after it boots to the default.

Comment 10 Bug Zapper 2008-04-03 19:03:07 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 11 Bug Zapper 2008-05-07 01:08:43 UTC
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp


Note You need to log in before you can comment on or make changes to this bug.