Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227738 - spamasssin (sa-update) needs gnupg
Summary: spamasssin (sa-update) needs gnupg
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-07 21:04 UTC by Milan Kerslager
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 17:50:58 UTC


Attachments (Terms of Use)

Description Milan Kerslager 2007-02-07 21:04:42 UTC
Spamassassin needs perl-libwww-perl (LWP::UserAgent, see line 92 in
/usr/bin/sa-update). This dependency is not required by spamassassin package
(RHEL3, RHEL4 and probably FC too).

Comment 1 Milan Kerslager 2007-02-07 21:46:24 UTC
sa-update needs gnupg to run succesfully. This should be in Requires too.

Comment 2 Theo Van Dinter 2007-02-07 21:48:15 UTC
(In reply to comment #1)
> sa-update needs gnupg to run succesfully. This should be in Requires too.

no it doesn't, actually, though gpg verification is highly recommended.

Comment 3 Warren Togami 2007-02-07 21:50:04 UTC
Bug #193100 already covers the perl deps, it just hasn't been pushed to FC6 yet.

Good catch with gnupg.  I didn't realize nothing else actually Required gnupg. 
I'll add that to rawhide, and it will be in FC6 eventually.



Note You need to log in before you can comment on or make changes to this bug.