Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227731 - Intermittent/recurring problem with luci service restart
Summary: Intermittent/recurring problem with luci service restart
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ryan McCabe
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-07 20:27 UTC by Len DiMaggio
Modified: 2009-04-16 22:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-08 15:55:01 UTC


Attachments (Terms of Use)

Description Len DiMaggio 2007-02-07 20:27:46 UTC
Description of problem:
Intermittent/recurring problem with luci service restart

Version-Release number of selected component (if applicable):
luci-0.8-30.el5

How reproducible:
25-30%

Steps to Reproduce:
1. Start and then restart the luci service - this fails sometimes - the result
is that there are (2) zope processes running
2. It's not possible to be more specific - nothing about the restart failure is
written to the zope or syslogs
  
Actual results:
See below

Expected results:
No failures

Additional info:

-----------------------------------------------------
Here are some example sessions:

Failure #1

[root@dhcp-10-12-34-204 ~]# service luci start
Starting luci:                                             [  OK  ]

Please, point your web browser to
https://dhcp-10-12-34-204.boston.devel.redhat.com:8084 to access luci


[root@dhcp-10-12-34-204 ~]# service luci restart
Shutting down luci:                                        [  OK  ]
Starting luci:                                             [FAILED]


[root@dhcp-10-12-34-204 ~]# !ps
ps -ef | grep zope
luci     10670     1  0 14:53 pts/1    00:00:06 /usr/bin/python
/usr/lib64/luci/zope/lib/python/Zope2/Startup/run.py -C /var/lib/luci/etc/zope.conf
root     11039     1  0 15:06 pts/1    00:00:00 /usr/bin/python
/usr/lib64/luci/zope/lib/python/Zope2/Startup/run.py -C /var/lib/luci/etc/zope.conf
root     11056  6711  0 15:07 pts/1    00:00:00 grep zope

=====================================
Failue #2

[root@dhcp-10-12-34-204 ~]# service luci start
Starting luci:                                             [  OK  ]

Please, point your web browser to
https://dhcp-10-12-34-204.boston.devel.redhat.com:8084 to access luci

[root@dhcp-10-12-34-204 ~]# 
[root@dhcp-10-12-34-204 ~]# 
[root@dhcp-10-12-34-204 ~]# 
[root@dhcp-10-12-34-204 ~]# service luci restart
Shutting down luci:                                        [  OK  ]
Starting luci:                                             [FAILED]


[root@dhcp-10-12-34-204 ~]# !ps
ps -ef | grep zope
luci     11697     1  5 15:15 pts/1    00:00:06 /usr/bin/python
/usr/lib64/luci/zope/lib/python/Zope2/Startup/run.py -C /var/lib/luci/etc/zope.conf
root     11815     1  0 15:16 pts/1    00:00:00 /usr/bin/python
/usr/lib64/luci/zope/lib/python/Zope2/Startup/run.py -C /var/lib/luci/etc/zope.conf

=====================================
Correct performance:

[root@dhcp-10-12-34-204 ~]# service luci start
Starting luci:                                             [  OK  ]

Please, point your web browser to
https://dhcp-10-12-34-204.boston.devel.redhat.com:8084 to access luci

[root@dhcp-10-12-34-204 ~]# service luci restart
Shutting down luci:                                        [  OK  ]
Starting luci:                                             [  OK  ]

Please, point your web browser to
https://dhcp-10-12-34-204.boston.devel.redhat.com:8084 to access luci

Comment 1 RHEL Product and Program Management 2007-03-21 22:09:30 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Kiersten (Kerri) Anderson 2007-04-23 17:08:19 UTC
Fixing Product Name.  Cluster Suite was merged into Enterprise Linux for version
5.0.

Comment 3 Jim Parsons 2007-05-08 15:55:01 UTC
Cannot reproduce


Note You need to log in before you can comment on or make changes to this bug.