Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227715 - suspend to ram produces soft CPU lockup.
Summary: suspend to ram produces soft CPU lockup.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-07 18:38 UTC by Han-Wen Nienhuys
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 2.6.20-1.2925.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-14 21:50:54 UTC


Attachments (Terms of Use)
stack trace (deleted)
2007-02-07 18:38 UTC, Han-Wen Nienhuys
no flags Details

Description Han-Wen Nienhuys 2007-02-07 18:38:04 UTC
Description of problem:

pm-suspend crashes while trying to suspend. 
Apparently, the crash occurs after I/O has been disabled, as
no trace is left in the syslog.  This is always reproducible.

Find attached a picture of the stacktrace.

This is with 

Linux haring 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10 19:28:18 EST 2007 i686 i686
i386 GNU/Linux

on lenovo thinkpad t60.


please let me know if you need more info.

Comment 1 Han-Wen Nienhuys 2007-02-07 18:38:05 UTC
Created attachment 147583 [details]
stack trace

Comment 2 Han-Wen Nienhuys 2007-02-07 18:39:22 UTC
note that the previous release 2869 did suspend correctly.


Comment 3 Stefan Becker 2007-02-15 09:27:21 UTC
Same here. Suspend to RAM only works with 2.6.18* kernels.

Duplicates: bug #227789, bug  #227639

Comment 4 Julian Sikorski 2007-02-21 23:39:17 UTC
Can this be a duplicate of bug #229464? The problem is that I rolled back to
2.6.18-1.2798 and it did not help. Can I download 2895 kernel somewhere to check?

Comment 5 Chuck Ebbert 2007-02-22 00:30:55 UTC
(In reply to comment #4)
> Can this be a duplicate of bug #229464? The problem is that I rolled back to
> 2.6.18-1.2798 and it did not help. Can I download 2895 kernel somewhere to check?

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/i386/

Kernel 2895 is still there.


Comment 6 Julian Sikorski 2007-02-22 00:45:25 UTC
I meant 2869, sorry.

Comment 7 Stefan Becker 2007-03-14 07:00:56 UTC
Suspend works again on my Lenovo Thinkpad T60 with kernel-2.6.20-1.2925.fc6 from
FC6 updates-testing.


Note You need to log in before you can comment on or make changes to this bug.